19.0-Matrix Discussion

Just played a video and enabled some debug log and video compinent logging. Hope you can find something:


Please collect full log, but don’t enable debug… to check your config
You have AAC audio in this file, so you should to use HDMI Multi Ch PCM and 7.1 channels in audio settings or HDMI and 2.0 channels

Ok, this is what I got as link for log and the Audio is HDMI and 2.0 set:

http://ix.io/2TCm

Could you try to set default resolution to 1080p and try to play video again?
Also did you have no issue on 9.2 -NG or non-NG build?

1 Like

Hi boot2k3,

I had no issues on 9.2 where I was using the non-NG builds. Did a complete clean install of CE19 but the only thing that doesn’t seem to work is the video playback as it simply stutters… ALready tried setting different resolutions but the only thing that helps is disabling the acceleration for h264 which again breaks IPTV Simple Addon in cutting framerate by around 50%

Did you try with cemmc tool ?

Hello everyone. Well I gave up. I issued it with a sick-note sd onto a card the
CoreELEC-Amlogic-ng.arm-19.0-Matrix-Generic.img
goes from a card but when I installed it and I withdrew it did not start then. More punctually until 5 seconds blue lamp then as if I relaxed it there would be red led

Did you also copied correct dtb file (gxl_p212_2g.dtb)?

yes rename dtb.img

And did you copied file to root folder (where kernel.img and SYSTEM files are)?

yes. rufus burn. and booting sd card.

Then repeat all the steps and be sure you are doing correctly.

let me lay it first back up the factory software? or I may install it immediately the libreelec after 8.2.3.1 immediately?

recovery x96s905x factory software and install coreelec 19 matrix…:

CoreELEC (official): 19.0-Matrix (Amlogic-ng.arm)
CoreELEC:~ # ceemmc -x

Starting CoreELEC eMMC installation tool...

System is not supported: gxl_p212_2g!

There is NO official support by Team CoreELEC
if you continue to run this tool!
Continue? [y]: y

eMMC size: 0x0003ab400000 [16GB]

No CoreELEC installation found on eMMC

Install in dual boot mode, CoreELEC and Android on eMMC
  Use CoreELEC data from
    [1] current used SD or USB device
    [2] existing backup on current used SD or USB device

Install in single boot mode, only CoreELEC on eMMC
  Use CoreELEC data from
    [3] current used SD or USB device
    [4] existing backup on current used SD or USB device

Please choose one option? [1/2/3/4]: 3

Free space of 'partition CE_FLASH': 512MB
Warning: Could not find 'dtbo' partition!
Warning: Could not find 'dto' partition!
Free space of 'partition CE_STORAGE': 14352MB

Used space of '/flash': 225MB
Used space of '/storage': 2MB

There is enough free space on eMMC for installation!

Install CoreELEC on eMMC.
Continue? [y]: y

Moved 'env' from offset 0x000027400000, size 0x000000800000 to offset 0x000000400000
Moved 'misc' from offset 0x000031c00000, size 0x000002000000 to offset 0x000006400000
Moved 'logo' from offset 0x000028400000, size 0x000002000000 to offset 0x000008400000

Starting to format the new 'CE_STORAGE' partition...
mke2fs 1.45.6 (20-Mar-2020)
/dev/mmcblk0 is apparently in use by the system; will not make a filesystem here!

Starting to format the new 'CE_FLASH' partition...
mkfs.fat 4.1 (2017-01-24)
mount: mounting /dev/loop3 on /media/CE_STORAGE failed: Invalid argument
Stopping Kodi before start of copy process!

Starting copying of data to the eMMC!
Please do NOT interrupt this progress till it's finished!

Copy all data from '/flash' to '/media/CE_FLASH'
        225.01M 100%   23.13MB/s    0:00:09 (xfr#61, to-chk=0/63)

Syncthing, please wait...
Copy all data from '/storage' to '/media/CE_STORAGE/coreelec_storage'
          2.82M  99%   12.50MB/s    0:00:00 (xfr#223, to-chk=0/439)

Syncthing, please wait...
Start Kodi again to have a user interface!

Success!


You can now power off the device, remove the used boot media (SD or USB) and
power on again to boot the device from eMMC!

CoreELEC:~ #

Error screen:

Error mount storage: mount_common could not mount /dev/ce_storage ***

X96 is not officially supported. Use uSD and not ceemmc!

what? how can I resettle it then?

i tried pendrive and sd onto a card to announce.
All the two times come on that mistake.

Anybody please?

You installed Ugoos firmware on Minix U22?
First: reflash Minix with a Minix firmware!
Second: run CE

Ugoos firmware is encrypted and do not boot CE anymore.

Dear CoreELEC team! First of all, thank you for your great work!
Regarding “CoreELEC decided to remove support of these SoC family because they aren’t supported anymore by Amlogic in newer kernel than 3.14.”
Did you see https://docs.khadas.com/firmware/Vim2Firmware.html especially Ubuntu releases with Linux Kernel 4.9 as well as Android Pie with Kernel 4.9.