8.95.5 CEC not working


#22

Disabling in the menu isn’t actually disabling it?

Just found this from googling, apparently that commend line made no difference and no one offered any other suggestions.


#23

No it’s not. The issue happens in uboot.
Try it first. If it doesn’t help then there is nothing we can do.
We don’t touch the uboot of every generic S905/12 box.


#24

Where do you run the command line? SSH?

EDIT: Looks like I fixed it by turning off CEC in android.

Thanks for your help.


#25

From ssh. Android does the same.


#26

I also had issues with CEC after updating to 8.95.5 (S912 box), but under the CEC settings a “Restore to default” -> Reboot -> setting again the desired values fixed the issue.


#27

I have the same issue, here is the pastebin : http://ix.io/1uRs and http://ix.io/1uRv
Downgrade to 8.95.4.3 doesn’t work too.
Thank you !


#28

Did you try this?


#29

Not yet, I’ll try it


#30

Hi.

I had the same issue. This happens due to a problem in uboot of these Amlogic boxes. The only clean way to solve it was to put an HDMI adapter without the pin 13:

[LINDY 41232 - Adapter HDMI](LINDY 41232 - Adaptador HDMI macho a hembra, negro https://www.amazon.es/dp/B00DL48KVI/ref=cm_sw_r_cp_apa_I96aCbY48NQKY)

Now, it’s solved! Now, neither the TV nor the AV get completely crazy when the S912 box is on or even in Preformatted textstandby, although I have lost the CEC control on it from the TV remote control: volume and other interesting keys. Then, I had to buy a Bluetooth keyboard for it.

I hope it helps.


#31

There is an easier solution. Create a Autostart.sh and echo cec3f to the cec sysfs (which will activate CEC) then create a shutdown.sh and echo cec0 to cec sysfs (which will disable cec).
This was uboot will always think CEC is off and not poll but kodi will have cec control.