9.0.2 Discussion

First thing I do when a new device arrives is to set an IP on my router. It’s a one-off 30 second process - until I change router. You can do that in DHCP settings on most (not all) routers.
Doing it that way there’s no problem taking something outside the LAN.

Yeah no problem it’s an easy thing to do and I did, added a network printer the other day where I needed a fixed IP so I just reserved all of the devices through the router. Still I’ll probably forget which IP goes with which device a week from now.

Set the DHCP pool start IP from x.x.x.100.
Then add your server devices a static IP below x.x.x.100.

@JimmyS sorry for the delay. Here is my debug log: http://ix.io/1Lff

I was having another issue with 9.0.2 where it was losing audio sync and causing the video to stop playing. I rolled back to 9.0.1 and it’s resolved.

EDIT: Seems like I’m still can’t pair back on 9.0.1. Getting Bluetooth dbus_error_handler: operation not permitted. I’ll try your nightly version update to see if that fixes it. Hopefully I don’t get the video drop error back

EDIT2: Nope, the drop out of the video is back in the nightly.
Read - Error( -1.103. Software caused connection abort
Got MSGO_ABORT or MSGO_IS_ERROR return True
What’s the difference between the CoreELEC-Amlogic and Amlogic-ng versions?

The Amlogic version is using kernel 3.14 and is meant for S905/S912 devices.
Amlogic-ng is based on kernel 4.9 and only works on the Odroid N2 currently.

Sweet, thanks for the clarification. I gambled and went the non-ng version :slight_smile:

You wouldn’t of been able to install -ng anyway, we have protection in the images to prevent people flashing the wrong update file.

Hi all.
Is there an approximate date to launch the next stable?
Thank you.

No, it’ll be released when it’s ready.

I recomend you use sdcard because you can easily get backup before disasters.And you can mount sdcard to any linux os and you can make repair easily.
I got fast samsung sdcard with 80mbs speed. Almost no difference between internal. Because the os is very small.

Hi… I check corelec commit on github very soon… (I’m waiting the videoplayback patch for s905 odroid C2) so… I went on xbmc github and saw that next kodi release will be without amldecoder support… To force using standard… (But rpi will still supported)… First They forgot their origin : software for specific system… Two : rpi is bullshit as mediacenter three : today kodi on x86 was interested before soc as amlogic… But not now.

1 Like

Well the CoreELEC guys did say they could support their own Kodi fork if they have to. In any case it will be a while before the next version is out. Not sure it’s set in stone yet on dropping AML, is it?

@Meeuuh92 this is not the place for this type of discussion but yes you are correct, the amcodec code was already nuked from Kodi master by the LE team.

@CraigHB yes we did and you can guarantee that this is exactly what we will do when the first Matrix Alpha drops, this is well over a year away though yet.

You guys have nothing to worry about.

2 Likes

Still got the Bluetooth issue after rolling back to 9.0.1, bluetooth:dbus_error_handler (Operation not permitted) in the log when trying the connect my Harmony remote to Kodi. Was working fine on 9.0.1 before upgrading to 9.0.2.

Personally i believe there will always be custom forks of Kodi as there always has been. Kodi in general is written for such a wide variety of OS’s and devices its just way to much work trying to make it excel on them all based on one build. I know thats what the attempted direction they are trying to follow but others will always fork it and make attempts at making it work better on their own devices thats the great part about open source software.

Matrix Alpha’s are already up and basically working beyond the currrent level of the Official github revisions and will only get better along with the Official sources moving forward but its still to early for Matrix to see where Amlogic will fall looking forward. a lot hinges on the sucessful completion and release of projects like Lima and Panfrost and a couple of still private developments in the GPU area regarding Arm’s GPU’s being currently used.

As adamg said i don’t think theres much to worry about at this point in time…

Hi Portisch, any insight into the Operation Not Permitted, dbus_handler_error I’m now getting when trying to pair my Harmony remote? I have tried removing the device in Harmony and re-adding it, but no luck and have to use the IR remote. I’ve also gone back to 9.0.1 which was working fine, but also get the same error. Thanks.

I don’t own a harmony but please make a dmesg log when this happens: dmesg | paste

Closing due to 9.0.3 release, further discussion here .