9.0.2 Discussion

Hi everybody, and thanks for the job… We waiting for a long time for this release… But I encounter some stability problems in video playback under client htsp, streaming videos, and h264 videos over samba … freezes video, ortm stop … I returned in version 9.0.1 on my two odroid c2

This is an issue in upstream Kodi that they introduced, we have already identified a fix and it will be in tomorrows nightly release.

This is not 9.0.2 specific, but it is an issue, or a behaviour, present in it.
Is there a specific reason why SD resolutions, such 512x400 are displayed with a 4k resolution, if white listed?
I think it would be better to display in 1080p, to let eventually the TV scaler to upscale it.
This is even more important if you use VPR with 4k interpolation, because they behave better (and are more silent) with 1080p
Please apologize in advance if this is something Kodi dependent.

Is this answer for the TVH / display resolution / or Meeuuh post?

Personally, I didnt encounter disp/streaming problems on my C2@home, but

  • I dont use TVH yet (and I will use only client).
  • I am using only samba client on C2’s

But my others installations are using TVH (server+client) with DVBT-2 tuner, and also samba (server+clients) - planned update when I’ll be visiting parents, so I am interested…

i want ssh enable by default like samba.

It won’t happen. See this post:

Thank you so much for fixing the bug that stopped us from using the infamous installtointernal. I know it’s unsupported. But I happily used it back in the days of LibreELEC, and because I never had any issues with it, I still wanted to use it after upgrading to CoreELEC. It’s faster than external memory and after all, I’ve paid for the internal memory, so why should I not use it. I just like the idea of CoreELEC really living inside the box, with no extra SD card or USB stick required. The crappy factory Android stuff is useless anyway.
So, again, thanks for your effort on fixing an unsupported feature!


Yesterday I Update CoreELEC from .1 to .2 and everything works fine except one thing…
I use pvr iptv archive client to watch IPTV but when I change channels somethimes after few changes somethimes after few more all system stuck and only whats work is unpluged box from DC.
I try also clean install and that not fix problem but when I downgrade version to .1 everything works fine… please if someone could give me any advice that would be great
Device which I use is H96pro+ 3GB/16GB

It’s fixed in today nightly

The problem was introduced by an upstream fix in Kodi. As mentioned, we reverted that change, and today’s nightly should work fine.

Hey! Enjoying 9.0.2 so far, however I’m having some problems with subtitles, it’s not specific for 9.0.2 but I’ve had this issue for some time. The text “shakes” sometime, it’s kind of hard to explain, so I’ll let this GIF do it for me. Any ideas what’s causing it?

Hello, does have anyone problem with install InputStream plugin?

When a install it, installation always fails. I have coreeleec 9.0.2 on Minix U9h.

Thanks for answer

@brtani please read and follow the instructions in my post here and see if it resolves your problem and let us know.

hi all,
I have a Vorke S912 and have been using CE since the start. i am trying to play a file with more “modern” encoding than i usually, and first time for me coreelec doesn’t play something. Sound works ok, but picture freezes within the first second of playing. Before i experiment more, i was wondering if simply i’m trying to play a file that isn’t supported.
The file is named “HEVC.12bit.DTS-HD.MA” and in Media player classic it shows these properties:
Video: HVC1 1920x804 23.976fps 871kbps [V: hevc rext, yuv420p12le]
Audio: DTS 48000Hz 6ch 1536kbps [A: dts, 48000 Hz, 5.1]

What do you think, am i trying to play a file that is way beyond the capabilities?

Did you try to install it from .zip file ?

I doubt 12bit hevc can be hardware decoded. Upload a sample and we’ll take a look.

Hi, i’ve tested last nighty build (15may) but I noticed some display bug on video stream that do not appear with 9.0.1. Maybe, the fix will be for tonight…


Yes, i tried several version (2.3.13, 2.3.15, 2.3.17,2.3.18) but that version that you send to me worked. Already it’s everything ok. Thank you very much.

What “display bug” did you notice ?

Rare artefacts in video playback and the video stop few seconds after pause/resume playback.