9.2.0 Discussion

The cache memory is not worth me since I use quasar since the reproduction is by torrent

This isn’t something we can help you with. No support for pirating.

Can anyone get auto power off to work? I have set it to 10 minutes, this is an update from long story of CE (LAST 9.0.3), but after 10 minutes of compete idle (including guy brightness reduction) the box is still on.


kann jemand testen der 9.2 auf der Odroid N2 besitzt, ob es bei im der Webgrabplus Docker von LinuxServer.io Installieren und benutzen lässt?

LinuxServer.io = v9.0.102.102
Webgrabplus aus LS.io = 1.0.2

Es wird erfolgreich Installiert.
Über SSH eingabe “docker images” wird der webgrabplus docker nicht erstellt, somit auch nicht gestartet

can anyone test who has 9.2 on the Odroid N2, whether it is installed and used in the Webgrabplus Docker by LinuxServer.io?

LinuxServer = v9.0.102.102
Webgrabplus from LinuxServer Repo = 1.0.2

It is successfully installed…
About SSH input “docker images” the webgrabplus docker is not created, thus not successfully started

maybe that will help? see the docker version, it is installed…

I noticed an issue with 9.2 and 9.0.3 that is not present in 9.0.2 and earlier. When playing 23.97Hz 720p H264 content on a Tanix T92 box the video will start off fine and after about 30 seconds starts stuttering every 2 seconds when H264 hardware acceleration is enabled. If I disable H264 hardware accelerating the video plays smoothly. The particular videos being played had aac audio also. Subtitles were also off.

What resolution and frame-rate is it being played back at ? have yo got the mediainfo of the file.

i have the same problem with H96pro+ (amlogic s912) but the problem is with Rpi 4 LibreELEC 9.2 beta 1 as well.
Here a while ago, I mentioned the problem !

I have mediainfo.

The resolution was set to 1080p 60Hz. Adjust display refresh rate is set to on start/stop and sync playback to display is off. Framerate of video is 23.976.

Here is media info.

Format                                   : Matroska

Format version : Version 4
File size : 1.59 GiB
Duration : 1 h 26 min
Overall bit rate : 2 623 kb/s
Encoded date : UTC 2019-08-14 14:04:12
Writing application : mkvmerge v31.0.0 (‘Dolores In A Shoestand’) 64-bit
Writing library : libebml v1.3.6 + libmatroska v1.4.9

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Main@L3.1
Format settings : CABAC / 4 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference frames : 4 frames
Duration : 1 h 26 min
Bit rate : 2 493 kb/s
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.113
Stream size : 1.51 GiB (95%)
Writing library : Zencoder Video Encoding System
Default : Yes
Forced : No

ID : 2
Format : AAC LC
Format/Info : Advanced Audio Codec Low Complexity
Codec ID : A_AAC-2
Duration : 1 h 26 min
Bit rate : 128 kb/s
Channel(s) : 2 channels
Channel layout : L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 SPF)
Compression mode : Lossy
Stream size : 79.4 MiB (5%)
Default : Yes
Forced : No

Updated Core Elec today and my Hyperion stopped working, so I updated Hyperion.NG too it is now working, but the menu has wrong color order. There is thread about it on Hyperion forum, and I have no idea where to submit a ticket, because last time to find someone to compile an improved version lasted half a year :smiley:

Can someone take a look at this thread (solution at the end, but I’m way too noob to compile myself):

For hyperion.ng I changed

switch (vinfo.bits_per_pixel)
case 16: pixelFormat = PIXELFORMAT_BGR16; break;
case 24: pixelFormat = PIXELFORMAT_BGR24; break;
case 32: pixelFormat = PIXELFORMAT_RGB32; break; // was PIXELFORMAT_ BGR32
Error(_log, “Unknown pixel format: %d bits per pixel”, vinfo.bits_per_pixel);
return -1;

For hyperion I changed

if (vinfo.bits_per_pixel == 16)
pixelFormat = PIXELFORMAT_BGR16;
else if (vinfo.bits_per_pixel == 24)
pixelFormat = PIXELFORMAT_BGR24;
else if (vinfo.bits_per_pixel == 32)
pixelFormat = PIXELFORMAT_RGB32; // was PIXELFORMAT_ BGR32

1 Like

I upgraded from 9.03 to 9.2 on Xtreamer Whizz. Everything went well apart from the fact that on the initial boot I had only black screen until Kodi interface kicked in. No worries

I ve noticed a small improvement in video playback both movies and TV. Motion seems a little smoother than before and deinterlacing more solid. Are there improvements or is it just my impression?

I have a Sony AF9 4K HDR tv and 2160p resolution


I have installed 9.2.0 on a UBS and booted on X96 Max 4/32 (with proper device tree), and I get green screen. Just as described here: Khadas VIM3 testbuilds

LG tv, tried switching different HDMI cable and HDMI ports on TV, no difference.

Cannot boot nighly build, getting a boot loop.
Adding: device is now based on Android9, with update, dated 20190926.
Update: tried to run nightly again with a tooth stick, and it worked. Coreelec loaded fine and no green!

@ffimon Any ideas on the stuttering issue based upon what I posted above?

1 Like

Hi All,

I have installed 2 new builds on an N2 and C2.

My N2 - CEC Fails

My C2 - SFTP is still broken for me. Has the latest fix been added to this build based on https://github.com/xbmc/xbmc/pull/16438

Thanks in advanced

Hi, where can I find the new coreelec splash screen? I want to put it in before kodi is loaded. Thanks

Change spalsh to your own:
Copy your splashscreen.png to your storage folder and rename it to oemsplash.png
then ssh the box, make 3 command and reboot. :

mount -o remount,rw /flash
cp /storage/oemsplash.png /flash/oemsplash.png
mount -o remount,ro /flash

Thank you very much for your answer but I wanted the beautiful splash screen with what coreelec 9.2.0 starts itself. I don’t know where to find it.

splash-1080.zip (917.7 KB)

Just unzip this file and follow previous instructions.

Thank you very much ukmark62.

I bought one for me to have some fun, I hope it does not have the same boards.