A95X F2 4G 32G ROM 100bit LAN

I am trying to install CE (tried both latest nightly and stable) on the internal MMC of an A95X F2, and after running ceemmc -v and choosing Dual Boot, although there are no errors, it fails to boot in CE and goes straight to Android. It does seem to flicker twice on the boot loader logo after this happens. If I boot back through the USB stick, and run ceemmc again, it does not detect that CE is installed.

If I try to perform a Single boot mode, the box will not boot anymore from internal, and have to boot either from USB stick or TF.

I then would need to flash the stock firmware back using USB cable to get it back to factory.

I want to get it to boot in single boot mode from internal. Has anyone managed to get the above box to do this please?

afaik from the ceemmc document, “ceemmc -v” is for supported devices only (Khadas VIM3 and VIM3L).

I used “ceemmc -x” on my X96 Max S905x2 and it worked fine, box now boots from internal. Option “ceemmc -x” is mentioned under “Unsupported devices” at the end of the ceemmc doc.

It’s not possible to install on internal using ceemmc on A95x devices.

Thank you for your prompt reply. Is this something that’s in the works, or just not going to happen. Also, is there a list somewhere of what works and what doesn’t please?

Check 7 messages starting from this one.


Only features that required bootloader changes don’t work. All other should work on this box.

Thanks again for your help. So basically this is due to vendor lock on the boot loader. I’ll resign myself to using tf or usb then.