A95X F2 S905X2 4G Remote, Wifi not working

Hello guys,

I just managed to boot CORELEC on my A95X F2 S90X2 device, but I can’t seem to use the IR remote which came with it, and also don’t have a working Wifi available.

Could any1 of you guide me to the correct path for making Remote and wifi work on this device.

Also is it possible to dual boot both CORELEC and Android?

Can COREELEC be installed or Replaced on Stock Android firmware,as DTS HD MA passthrough and Dolby TRUE HD are my priorities.

I confirm that using CoreELEC, I’m able to watch videos encoded in DTS HD format, but it’s an Hassle as I don’t have a working remote nor a working wifi.

Can’t use ethernet as my router is far.

I think that we currently don’t have the Wifi drivers for this box in CE.
To setup the remote use this guide: How to configure IR remote control

Ok, luckily for now, my Sony TV’s remote is working with CoreELEC, but I can’t control the volume of A95X, hope it is set to full by default otherwise, I’ll have to raise my Reciever’s volume which is not desired.

Thank you developers for making this build, my A95x plays anything I throw at it, including Dolby Atmos, DTS HD MA etc. My AVR is showing Dolby trueHD, DTS HD MA with coreELEC.

I boot from the USB flash, then connect my HDD to USB3.0 port. If i connect HDD and USB flash it doesn’t boot.

Also thank you, for the link, but I’m a novice and don’t know how to configure IR remote.

That is understandable, the link has instructions what to do. You can also find an existing remote config file for other A95X boxes, it will probably work just fine with your remote.

I also have the same box and for remote just use this remote.conf . Put it in .config folder with winscp and reboot.

remote.conf (2.4 KB)

For wifi I use an external usb wifi adapter tp-link wn823n v1 , chipset RTL8192CU. It works perfectly in Coreelec.

Do long press functions (eg scrolling) work with this .config? Thanks …

Yes I can scroll ahead a video keeping the right arrow pressed for example

I guess I asked wrong. I meant, for example, scrolling the menu, movie list, or volume by long pressing the navigation buttons.

Yes you can scroll with long press

Thank you for answer. I put your remote.conf file in the /storage/.config directory
The remote control works but the long press of the navigation buttons does not scroll. I have to click repeatedly to scroll through the items. I’m doing something wrong?

I have no idea , in the addons I use if I keep long press it continues to scroll and it stops after I release it …

Just to be sure - are we talking about the same remote?

Yes, the only different key is in the last row on the left. I never use this remote though, I use it just to turn box on, then I use the app Yatse on cell phone. Much more convenient.


Which dtb file did you use? I haven;t gotten my box to boot. I think I have tried all the g12a variants.
I can boot into arbian and libreelec19 using Balbes150’s test build

You have to follow advice of Balbes and completely wipe and reinstall your device because of the modifications his builds have made to your device.

I didn’t install his build to internal, only ran from SDCard.
I have since used twrp to flash the stock rom again though.
I have tried using a “dd if=/dev/dtb” img that I created myself too and CE still doesn;t boot.

It doesn’t matter where you run it from it still makes changes to the bootloader.

TWRP does not do a full recovery as it does not backup and restore the env partition which is where Balbes makes his changes.

I have already told you what you need to do to run CE, doing anything else is wasting your time.

OK. Appreciate your guidance and your knowledge.
I was only providing an FYI of what I have already tried. I will perform the USB Burn flash later today.
I have tried looking for the “advice of Balbes” that you mentioned in your first reply but I couldn’t narrow down where to look. He is a very active developer across many sites/projects/forums

(this is not a “instead of following your suggestion”, this is just an idea that popped into my mind) - Another thought I had was trying to combine the system partition of CE with his boot partition of LE.

I found a thread during some of my reading that so long as there is the s905autoscript, this new style of booting can be adapted. Would this be an easy task for someone like myself with a little knowledge of linux (little enough to be dangerous but not enough to be efficient. lol)

Go and ask Balbes.
He has his own theories on what he injects your bootloader.