AAC 5.1 Stuttering on Odroid N2

Hi folks,
Using an Odroid N2 connected to an Onkyo receiver and then to an LG OLED I have noticed that none of my 5.1 AAC contents works with any of the nightlies. It does work on the stable 9.2.1 but I have other issues with black screens occuring all that time that are fixed in the nightlies meaning I have to stick with them. I tried multiple different sources of 5.1 all with the same results.

If I encode another 5.1 source type like DD of DTS to aac with DB PowerAMP I get the same result but if I encode a 5.1 DD, DTS or AAC to 2.0 AAC it works perfectly fine.

I know the sources are fine as they play fine with VLC on my computer and with LibreELEC on my NUC.

The audio output selection on the Odroid N2 is ALSA: AML-AUGESOUND, HDMI if that means anything but is anyone experiecing similar issues?


I have the same issue on both N2 and LePotato (with the nightlies). It does work fine in 9.2.1. The workaround is to turn your Audio settings from 5.1 to 2.0 then it plays fine. With anything but 2.0 the stuttering happens.
I think its a clumsy fix, but it is a fix.

On N2, kodi settings you need it to set on HDMI multi ch.

I tried this and it does work. I’m concerned that it’s decoding everything to PCM instead of passing the stream to my DAC. It gives various readings after light testing. DTS seems to passthrough but ATMOS seems to be decoded. Not a complete test but I’m not sure. It would be nice just to use CoreElec without all the fiddling because of a few files.

You need to enable passthrough in order to get passthrough.
Formats that can’t be bitstreamed will be decoded and sent out as multichannel pcm.

I have enabled passthrough, but now I understand. Thanks.

Thanks, thats sorted it.