AMLOGICGRABB stops working after couple hours -


I just installed on my second S912 Mecool M8S Pro L device and I noticed weird thing with my new installation. Everything works fine but after certain amount of time my AMLOGICGRABB stops working until I reboot the device. Usually it happens when I’m not using device for a longer period of time ie. 10h and up or when I wake up the next morning and try to watch something. Rebooting the device fixes the issue until next occurrence.

Here are logs:

As you can see it errors out at :
2020-10-05T11:31:01.461 hyperiond AMLOGICGRABB : <ERROR> Read of device failed: 61 - No data available

I tried to search the forums for similar issue but I haven’t found any meaningful solution - just some posts in the N2 section. It’s weird as my other S912 device KIII Pro doesn’t have this issue. Both devices use the non ng version of CE.

I’m posting it here in CE forums as I think that AMLOGICGRABB is part of the system, not the Hyperion itself?

Thanks for your help!

That’s not it I’m affraid. I don’t use AtmoORB - I’m using adalight based on Arduino UNO and it’s directly connected via USB to the CE box.

Let me try that again: your will have more luck getting an answer asking your question in the Hyperion forum. Thank you.

There are no versions information. Not from CoreELEC used, nor from what Hyperion.NG version what got used. Before reporting any error please make a fresh CoreELEC install, maybe on another boot media with minimum of user addons installed.

There where no changes in last months so I see no reason why this should happen.
Maybe the cooling of the one device is better than the other one and the thermal temperature rise over night will lead to this affect!?

1 Like

@Betatester I’ve asked before in the Hyperion forums and got instructed to ask in the CE forums.

@Portisch Sorry about the lack of the informations. The CE version is, is 9.2.104 based on 2.0.0-alpha.7 and Hyperion Control is 1.0.1

This is a brand new Hyperion installation on this device and I had it only for couple days now so it’s not something that was working fine before on this device and suddenly stopped (at least for me). What I noticed is that besides rebooting the device fixing the issue, also changing any param in the LED Hardware section and reverting it back to what it was before also fixes it - most likely restarting Hyperion daemon in the background.

The cooling also isn’t the factor here as I have a modded case for my M8S Pro L with extra fan at the top to fix thermals.

In the upcoming days i’ll prepare a bran new CE installation with only and maybe YouTube to test it and I’ll post the logs from CE and

Thank you!

@Portisch @Paulchen-Panther Sorry for the delay but I’m back with more details on the issue. I made a brand new CE installation with, Hyperion Control and TvH Client addons only. The issue still exists.

Here’s the debug log from

As you probably notice there’s this in the log:

2020-10-17T16:17:51.036 hyperiond LEDDEVICE : ProviderRs232.cpp:95:close() | Close UART: ttyUSB0
2020-10-17T16:17:51.036 hyperiond LEDDEVICE : Device disabled, device ‘adalight’ signals error: ‘Rs232 SerialPortError: Input/output error’
2020-10-17T16:17:51.038 hyperiond COMPONENTREG : ComponentRegister.cpp:36:setNewComponentState() | LED device: disabled

Maybe it’s related to the issue you reported earlier @Portisch: Hyperion.NG, Amlogic improvements

I have also full Kodi logs if they will be required.

Also I can confirm the issue with wrong red/blue colors when in Kodi menu or when viewing pictures via Kodi as in this report: Hyperion.NG, Amlogic improvements

Here are 3 pictures. The one with wrong colors is a prepared png file with 3 columns to present the issue. The other two pictures are from video playback where the colors are proper.

Thank you for your support!

So it does work but on some videos it does not work? h264 is working, h265 not?
Can u please upload the 3 color png that I can re-check this? My GUI window shows red correct.

And a baudrate of 500000 over a USB RS232 adapter? You can be glad if you can reach 115200!

Instead of RGB image, check with an RBB.
If the middle area gets red, its an issue with color detecition.
I expect it gets blue, in this case your LED chain definition is somehow wrong, mirrored L/R or rotated 180°.

@rho-bot thanks for the hint! Mystery solved and it’s a bug. My led strips are glued counter clock-wise (when looking from the front of TV) so I had to enable the “Reverse Direction” in config. This seems to be properly respected by playing videos but not when displaying pictures etc. I consider this to be a bug.

@Portisch It works just fine in all type of videos. And I had to set the baudrate to 500000 because on 115200 the leds were very slow and choppy. I’m also surprised that it works fine but they are now super fluid. This is the case for both M8S Pro L + WS2812B + Arduino Uno and KIII Pro + APA102 + Arduino Nano.

The only and most important issue right now is why does disconnect my Arduino Uno connected to M8S Pro L and WS2812B after couple hours of being idle. My other KIII Pro + Arduino Nano device works perfectly fine.

Maybe it has something to do with power control? Maybe the M8S Pro L doesn’t keep the USB power up constantly and that’s why its disconnecting the Arduino Uno board? I have another board laying somwhere in the house so I can try to replace it to make sure that the board itself is not faulty.

Although if this would be the case would simply resaving the “LED Hardware” section in dashboard fix the issue like it’s doing right now?

Or maybe you have some other ideas?

1 Like

Ok, I’m back with a new log. It looks like it’s not AMLOGICGRABB that’s the issue.


As you can see in the log I stopped watching stuff in CE at 17:23:22 and then by itself at 21:01:14 this happened:

2020-10-23T21:01:14.908 hyperiond LEDDEVICE    : <DEBUG> ProviderRs232.cpp:95:close() | Close UART: ttyUSB0
2020-10-23T21:01:14.909 hyperiond LEDDEVICE    : <ERROR> Device disabled, device 'adalight' signals error: 'Rs232 SerialPortError: Input/output error'
2020-10-23T21:01:14.909 hyperiond COMPONENTREG : <DEBUG> ComponentRegister.cpp:36:setNewComponentState() | LED device: disabled

Do you have any ideas why it would happen? Should I take it to the github issues page since restarting hyperiond solves the issue?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.