Anyone has these boxes with Coreelec?

Hello, I’m in a process of buying a tv box which I will use for Coreelec and watching movies from an external hard drive, I don’t need it for anything else. Just a simple plug and play.

I found these near my location:

Tanix tx3 mini S905W (2GB RAM + 16GB ROM)
X96 mini
Tanix TX3 MAX
TX6 mini
M10 Pro

Does anyone have any of these boxes and can confirm that Coreelec is working on one of them without any problems like remote not working, complicated installation, crashing… the best scenario would be to have Coreelec installed on SD card like I had Libreelec till now.

If anyone has any of these players and it is working great with Coreelec can you just reply with the model you have, what amlogic (example S905W), is the remote working normally, do you have any problems and what was the process of the installation (example made the SD card, insert it, pressed reset button and plugged in the power cable).


I have a X96 Max + with 19.1 Leia (legacy) installed to SD card. Some addons aren’t working with the Matrix version. Chip is S905X3. Installation process is the same as LE. Burn image, press reset button etc. There is an installation guide on this forum, there is also a guide & a repo for remotes.
Apparently, there are temp issues with this device, but my temps don’t get so high that it causes a problem.
I found the inbuilt blue tooth didn’t work reliably, so I bought a dongle.

Confirming CE 9.2.7 and Matrix are both working without issues but for suspend. CE can be run on both from SD Card, USB Flash drive and eMMC. Installation process: toothpick or “reboot update” from console. For Matrix, many 3rd party addons are still unsupported.

I’m in same boat looking for a box but I’m considering its working conditions on more topics such as 4k, HDR, Tone mapping, Upscaling from 720p/1080p to 4k, HD audio etc. Please comment on those in the list.

What does this mean?

I have just tried it with a x96mini (905W, 2gb ram, 16gb emmc) and it works fine from SD-card.

Installation on emmc also works fine, Edit: all fine, was just missing net connectivity.

Edit: IR remote that comes with it doesn’t seem to work.

Maybe you could try looking here first and see if you can find a compatible remote configuration?

Ah thanks. After copying the remote.conf into the /storage/.config is there anything else to do than reboot? Because it still doesn’t seem to work, but I am probably just missing something :wink:

Let’s maybe start with the basics. Does the remote turn the box on and off?

“Did you try restarting your PC?” :wink:

Joking aside… it seems completely non-functional. No on and off either.

I have a X96 Max+ Q2. The latest CoreELEC and EmuELEC are working, including sound, bt, wifi, ethernet, DS3. I haven’t tried the remote controller.
Mind that there are at least 4 variations for X96 Max+, including Max Plus, Max Plus2, Max Plus Q1, Max Plus Q2. More details can be found on Russian website

There’s your answer, the infra red receiver from the box and the remote are not communicating with each other. Do you have another remote? The first ‘test’ always should be to see if the remote turns on the box.

As a basic check, you could check with your Smartphone camera, if there is any IR light sent from remote when pressing a button.

Yes the Remote is working (I can see the IR light in my smartphone camera) and it is the official one that looks the same as on the picture in the repo for the x96mini above.

It seems there is a build in IR reciever and one that can be plugged in with a cable. But through neither it works. I actually never tried it on Android either though :wink:

Maybe some issue with running coreelec from emmc?

Maybe have a look at some of these settings:

You always can use a USB mouse or keyboard for navigation

Basically none of these options exist on the x96mini. It does have a IR Protocol Type setting though. Switching through all of them seems to have no effect, but maybe it needs to be rebooted to have an effect? Edit: Also tried rebooting with “NEC” and “NEC Legacy” but no effect :frowning:

That’s what you are looking for. Try every option there and reboot after each change. Right now it looks like the IR onboard receiver is not recognizing the signal from the remote. Hopefully, by switching through protocols, you might find one that helps the receiver recognize the remote signals. If the system becomes unstable or unusable, just write a new boot media. It only takes a minute or two.

Another option you could explore is: CoreELEC BL301 Wake-Up feature [inject_bl301]

Could you provide a picture of the remote and device (can be a stock picture from the net)? The x96mini comes bundled with a couple different remotes.

The bl301 inject option is not available on the x96mini.

The remote looks the same as on this picture here: remotes/X96 Mini.png at main · CoreELEC/remotes · GitHub

Do you feel confident trying to catch remote codes as shown here?

Mostly I’d like to figure out if there are codes showing when pressing buttons.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.