Audio Sync Issue

Original N2 4gb too. Some nightlies are slightly better but nothing after 19.3 has been perfect.

1 Like

Just to let you know it is not only related to N2;)

I was going to say it looks like everyone with the issue is using the original N2. What do you have @loki7777?

x96 max plus s905x3

1 Like

My issue with setting delays, etc is that it shouldn’t be required. Playback in 19.3 is spot on.

1 Like

Chiming in to say I tried 19.5rc2 and get those issues too, on a n2+. Back to 19.3 and solid again. Bit concerning still no fix as yet, would really like to help pinpoint the issue somehow.

1 Like

That’s the point: somehow. I can’t fixed anything what I do not see.

I also rolled back to 19.3
No syn issues after pause.
No problems with Stereo Upmix not being enabled after restart even it looks like it is enabled. Can somebody fix these issues. The occur on 19.5 rc2 and on nightlies too.

1 Like

Hi Portisch, wondering if i could help demonstrate the issue. I was thinking to play a video normally, then pause, then resume… then i ensure that the video sync has broken… then what to do to create some sort of log or ssh command while the sync is broken?

If you have some sample and timestamp on that this issue could be repeated every time then please share a sample and timestamp…
In logs there is nothing that point to real issue and it doesn’t repeat every time.

Curios, and just for the record. I have now in newest RC or in both nightly (19 and 20) also a sync problem on N2 with audio. Not only after pause a movie/tv-show like before, its from the start on. But if I set audio to +0,175ms for all… its gone and fit perfect to lip sync in the scenes. That is very strange. I recognize this in original English movie last night. Cause in dupped German movies its not so much visible, cause the dup is not ever sync with the English lip movement… All CE test was fresh installment with Emby in native direct play and N2 direct connected to TV and audio via HDMI to Receiver. So its not a big deal to leave it this way, but its very curious and fyi…

1 Like

Say this thread on reddit today about the same issue, but with vanilla Kodi.

Yeah,something’s up with sync after Kodi 19.3, which had perfect sync. All higher than 19.3 have a diff of .175ms on win+ce for some reason.
I am quite sensitive to this and immediately notice it unfortunately :slightly_smiling_face:

You might want to file an issue at Issues · xbmc/xbmc · GitHub with example files to have that looked at.

This is not a Kodi issue. It’s related to the last kernel rebase. But non of our dev can reproduce the issue what does mean we can’t fix it.

Still happens in Nexus alpha 3. Has anyone tried a new software version with the dtb from 19.3? Would that work? I don’t have the know how to do it, just wondering if it’s an option.


I’ve been dealing with this out-of-sync issue after pausing for a long time. Currently on 19.5rc2
I usually find that going back 10secs ‘fixes’ it.
Happens so frequently we are used to it but it’s a pain. Perhaps I’ll try going to 19.3. Will see how it goes and will keep an eye on this thread to look out for a fix.

19.3 is spot on. I’ve tried that many versions after 19.3 and they all have the issue. I’m resigned that I’ll just keep 19.3 on my device and be done with it. I used to run nightlies but can’t deal with the audio.

1 Like

I don´t understand, none of the developers can reproduce this issue.
Me to, I have no sync issues on my CE boxes.

Must be something special at Your setup

Can still confirm. If fresh install or update my old installation 19.3 or 20alpha. If I go through receiver or connect directly to TV via HDMI, from 19.3 on out of sync. If I speed up to +175ms for all sources and pause a movie or tv show, its not that visible. But I can live with after pause to do a 10 sec. back, cause I do not often pause a movie or tv show.