BeeLink GT King - CoreELEC-Amlogic-ng.arm-9.1-nightly - Generic

Just installed nightly build CoreELEC-Amlogic-ng.arm-9.1-nightly_20190722-Generic.img.gz.
During boot I get the message:
Your devicetree is out of date.
Please update it to resume normal startup.
Normal startup in 60s…

Question 1: how to update the devicetree (in 60 seconds)?
Question 2: why countdown for 60 seconds as CoreElec will boot anyway with the outdated devicetree?

Thanks for all the great work the CoreElec Team is doing.

Baderks

p.s. Feel free to move this post to another category if this one is not appropriate.
.

Updating the device tree is a copy and paste job on your computer, follow the exact same steps that you did when you first installed CoreELEC ie copy from device_trees folder and rename.

The countdown is there to make users aware that they need to update the device tree.

OK. I did create a SD with the nightly build CoreELEC-Amlogic-ng.arm-9.1-nightly_20190722-Generic.img.gz and moved the BeeLink GT King devicetree to the root directory of the SD and renamed it to dtb.img conform the installation instructions for CoreElec.I then inserted the SD in the BeeLink device. As expected, CoreElec started a clean install on the SD. However, all I wanted was the upgrade of my CoreElec installation running on an USBstick to the 20190722 nightly build. When I follow the normal update instructions by copying this nightly build to the .update directory I get the message:
Your devicetree is out of date.
Please update it to resume normal startup.
Normal startup in 60s…

The solution is to somehow copy the SD image to the .update folder of CoreElec. But how to do that under Win10? Please give me some guidance.

TIA, Baderks

Plug your USB drive into the PC, and replace the DTB.

.

Thank you. That did the trick. I’m a bit embarrassed that I did not think of that myself.
Maybe it would be wise to amend CoreElec’s How to update CoreElec with this instruction to update the devicetree.
What I do not know is whether or not the update of the devicetree is needed every time you update CoreElec. If that is the case, it would break the automatic update of CoreElec.

Thanks,
Baderks

No, you don’t need to update the dtb in the future, it is automatic.

Hey there,
I’m having trouble getting the remote to turn off the box. I’ve the remote.conf file suggested above and that solved the problem of not being able to turn on the box with the remote after turning it off.
But how can i make it turn off or suspend with the remote power button? Any CLI command to get the keycode sent with i press the button to check what’s being sent?

Thanks,

The vendor bootloader does not support wake up. I am currently working on a small tool to fix the wake up errors. I guess in the next 2-3 weeks… There will be than a how-to guide on this forum.

After placing this boot2k3 remote.conf file in /storage/.config/ I was able to use the remote to switch on/off my BeeLink GT King box.

I’ve placed that file in storage/.config and now I’m able to turn on after shutdown/sleep but when in kodi if I press the power button nothing happens. I would like it to show the power menu or shutdown/put the box to sleep.
My remote doesn’t have the air mouse function… Could this be the issue? Maybe a different id?
Thanks for your help.

My remote is without mouse as well. So that is not the point.
You can use ir-keytable (available on CoreElec) to see what keys are picked up by the BeeLink GT King and what code is generated. Lots of info on ir-keytable available on the internet.
I do not know with what action you can replace the power action in the remote.conf file.to show the power menu. Changing this action could also break the power on part of the power action.

Success with your endeavour.
Baderks

Hello friends, the Orbsmart S86 works too with this image.

Great to hear, which DTB are you using with it?

I use “g12b_s922x_beelink_gt_king.dtb”

1 Like

By using remote.conf posted early I can power on the box, but not power off. I managed this file to get it power on and off by using the original remote.

#amlogic NEC remote
factory_code = 0x7F800001
work_mode = 0
repeat_enable = 1
repeat_delay = 120
repeat_peroid = 33
release_delay = 121
debug_enable = 1

key_begin
0x59 116
0x51 116
key_end

1 Like

Recently, using the GT King as an alternative digital VCR, there were to my surprise moments that I was able to transfer files from my PC to the GT King with speeds of over 100 MBytes/sec. Furthermore I was able to record TV programs from all the 6 network tuners simultaneously without any so called “continuity counter” errors. I was running Amlogic-ng Generic nightly 20190818 at the time. As I had not done anything special to get these ethernet speed results, I was convinced that the CoreElec Team had somehow solved the ethernet problems of the GT King.
Unfortunately, after updating to Nightly 20190820, the ethernet party was over again. Maximum ethernet speeds drop back to 67 MBytes/sec and I got lots of “continuity counter” errors from TvHeadEnd42, even during single tuner recordings. Although the maximum speed of 67 MB/s is better than the 20 / 40 MB/sec it used to be, it was a disappointment, especially the TvHeadEnd errors. By the way, 67 MB/sec should be more than enough for single tuner TvHeadEnd recordings (10 MBytes/sec per tuner maximum needed at the moment). So it is not speed alone what causes the current ethernet problems of the GT King.
That I was able to get ethernet speeds of 100+ Mbytes/sec, suggests to me that it is not very likely that the GT King’s hardware is the cause of the ethernet problems. Remembering the iperf3 trick I used to bump the ethernet speed to 40 MBytes/sec a couple of weeks ago, I tried this trick again. And yes, it worked again, be it that this time this trick, after a reboot of the GT King, bumped the speed all the way up to 100+ MBytes/sec.
Somehow iperf3 changes the ethernet settings in such a way that after rebooting the ethernet performance is what it should have been out of the box. These altered settings survive reboots and power off-on cycles. Why the initial reboot is needed after running iperf3 before these iperf3 settings are actually applied, is beyond me.

I hope this information will help Team CoreElec to once and fore all solve the ethernet problems of the GT King. Let me know if I can be of help or if more info is needed.

TIA, Baderks

.

I’m pretty sure that most of the problematic GTK has a hardware error, like the wrong resistor value soldered to the RX line. Maybe yours is an exception, but you never know with these Beelink boxes…
Just today I read about two GTKs arrived yesterday with non working gbit LAN.

This is now a well documented problem with this device, the Khadas VIM3 uses the exact same RTL8211FD ethernet transceiver with the exact same driver and the exact same kernel and the exact same settings and does not exhibit the same issues, some GT-King devices run perfectly fine at full speed whilst others do not.

It’s just like Adam says. As I’ve said in multiple occasions I was lucky and I don’t have ethernet problems. Others simply can’t use ethernet. And we tested both CoreELEC and android and it worked in similar fashion in both.

once CoreELEC is loaded and working on GT KING with nightly is it good to switch to stable

About | FAQ | Terms of Service | Privacy Policy | Legal Notice