Beelink GT1 Mini & CoreELEC, No USBv2 Port

CPU, GPU, Video Playback, Connectivity, USB, Power Supply, Dimensions and Weight all exactly the same.

Memory, the original also shipped w/2GB of RAM.

Storage, the original also shipped w/16GB of RAM.

Video & Audio Output almost reads exactly the same except for the original only w/HDMI 2.0a and the Mini-A shipped with HDMI 2.1

Like you say it uses the same dtb file, so it’s very strange.

Post time 2019-05-10 17:14:36

Figured it out thanks to you ( TheCoolest )! :slight_smile:

The issue with GT1 Mini is the USBv3 port isn’t the blue colour-coded port for quick identification, that’s next to the Micro-SD / TF reader. It’s actually the black colour-coded port that’s actually the USB-v3 port.

There need to be a specific DTB for GT1 Mini, because the parameters used for calling needs to be reversed.

How do you know that? And how does this solve “not working usb”?

And how is anyone at CE team able to get the Android DTB from your box ?
Unless you extract it and upload it to compare.

Well considering the black coloured USB-port is NOT suppose to be USBv3 port… Take various official Beelink flashing tutorials I’ve seen thus far, the USB-OTG port for flashing is always over the black coloured USBv2 port.

Remember I only had one working USB port, it’s the blue coloured and that suppose to be an USBv3 port. It’s the only functional USB port under CoreELEC.

Then one simple ssh command…, well I’ve used two, that clearly speaks volumes.


At this time I can only use it as a charging port. Hard to believe that this can’t be corrected, considering GT1 Mini-A uses the same dtb image and works fine.

I don’t have GT1 Mini-A, just the original GT1 Mini, but I bet the USB ports are likely properly coloured on that other one. At this time I only can use the USBv2, when I should be using also USBv3.

CoreELEC (official): nightly_20200116 (Amlogic-ng.arm)

CoreELEC:~ # dmesg | grep xhc
[    4.716572@3] xhci-hcd xHCI Host Controller
[    4.719544@3] xhci-hcd new USB bus registered, assigned bus number 1
[    4.727796@3] xhci-hcd hcc params 0x0228fe6c hci version 0x110 quirks 0x20010010
[    4.736206@3] xhci-hcd irq 14, io mem 0xff500000
[    4.761563@3] usb usb1: Manufacturer: Linux 4.9.113 xhci-hcd
[    4.767199@3] usb usb1: SerialNumber:
[    4.780520@3] xhci-hcd xHCI Host Controller
[    4.785924@3] xhci-hcd new USB bus registered, assigned bus number 2
[    4.821277@3] usb usb2: Manufacturer: Linux 4.9.113 xhci-hcd
[    4.826912@3] usb usb2: SerialNumber:
[    5.111346@3] usb 1-1: new low-speed USB device number 2 using xhci-hcd
[    5.262024@3] input: HID 6901:1224 as /devices/platform/ff500000.dwc3/
[    5.319887@3] hid-generic 0003:6901:1224.0001: input,hidraw0: USB HID v1.10 Keyboard [HID 6901:1224] on
[    5.326225@3] input: HID 6901:1224 as /devices/platform/ff500000.dwc3/
[    5.384283@3] hid-generic 0003:6901:1224.0002: input,hidraw1: USB HID v1.10 Mouse [HID 6901:1224] on

CoreELEC:~ # lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 6901:1224
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
CoreELEC:~ #

Here’s what we know…;

Two ports are both functional under Android, however under CoreELEC latest…, only USB that’s functional is the USB version 2 which is incorrectly colour-coded as the blue port on this here GT1 Mini box.

USB version 3 is recognized in CoreELEC but different types of drives and other types of USB devices does not work. However It can be used as a charging port, during the operation of box and running CoreELEC.

GT1 Mini-A pretty much same box, and uses same dtb image, the both USB ports works. I don’t know if the USB ports are properly colour coded on that one, I imagine It might be.

… Alright. I give up, thanks anyways.

What revision do you have?
S/N 95X2 or B95X?
And also link on full dmesg log collected after CE start:

1 Like

Hi boot2k3.

GT1 Mini, S/N: 95X2… The CPU is revision b. This one w/ 4GB of RAM, 64GB of Storage.

Thank you. :slight_smile:

From 1st view I don’t see usb related difference in android and CE dtb files

I have same issue .(sn: 95X)

Definitely a difference when I’m booted into Android, I have two perfectly functioning ports to be used and just the one functional USB under CoreELEC. Not only am I missing out on the High-Speed USBv3 port, but the convenience that it brings by having two functioning ports.

Also multiple shared issue reported on these forums.

Fresh boot, Paired Bluetooth, Playing music from phone to box, no audio.


(udevadm info /sys/bus/sdio/devices/sdio*):


(systemctl status brcmfmac_sdio-firmware-aml.service):

It’s a shame that we can’t update our own initial posts on these here CoreELEC forums… Because first thing I tried was change USBv2 to USBv3 for title description.

Here’s another problem. Use ’ Suspend ’ TV shuts down, and my box turns off, light goes out.

Press Power button on my box remote, the box lights up. TV however remains turned off. Yet I’m able to shell the box. Noticed doing lsusb -t, only showing hubs nothing else like it always does with the Air-mouse plugged in.

If I start the TV up manually, no HDMI signal. If I try pressing the remote power button, the box doesn’t power down. Also using journalctl -f, unplugging and then re-plugging the remote receiver, doesn’t ever trigger a single event… so there’s no USB ports whenever I resume from ‘Suspend’ plus the TV never comes on when trying.

Hi kevinjhd, thanks.

On another post you said that you have GT1 Mini (Amlogic S905X2 4GB/32GB), mines 4GB/64GB. You also said that you don’t have a working USB v2.0 port. Is it actually USBv2? Are you going by the colour-coded ports? Because with mine, the USBv3 port is the one that doesn’t work, and It’s incorrectly colour-coded, so It’s actually the black port for USBv3.

I’m using Android now, so I’ve forgotten which one doesn’t work, USB2.0 or USB3.0. Anyway, one can’t be used.
But in 9.2, I remember that both USB2.0 and USB3,0 worked.

I started off on CoreELEC 9.2.1, and it hadn’t worked with the public release. I switched to the Nightly builds and still testing with those. Maybe CoreELEC 9.2.0 worked, 9.2.1 broke support again?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice