Beelink GT1 Mini & CoreELEC, No USBv2 Port

When I’ve first created this topic, it was before I investigated deeply into the USB issue. I later discovered that the GT1 Mini (Amlogic S905X2 4GB/64GB) USB ports was incorrectly colour coded and I’ve posted my findings on this here topic.

and following that basically…

Interesting. Plugged my phone using USB Type-C cable, into that non-functional USB port on my GT1 Mini. Screen on the phone came on but there is an exclamation mark and not charging. :stuck_out_tongue:

Here v1 for testing

here another test version. we have no test object and no schematic so I can only guess what could be wrong.

EDIT: updated dtb files

This dtb work for me, I’m only using the latest CoreELEC-Amlogic-ng.arm-9.2.5-Generic Stable? Not using the CoreELEC 19 Matrix nor nightly builds.

the dtbs are for both, doesn’t matter. just try it…

Here v2 for testing:
g12a_s905x2_2g_1gbit.dtb (66.5 KB)
g12a_s905x2_4g_1gbit.dtb (66.5 KB)

Apologies for the delay. Alright, tried version 1, every-time I boot CoreELEC there’s an ‘Pulse-Eight CEC Adapter’ error message and the same error shown on the phone when plugging it in, no LED with USB flash drive either.

ignore the CEC message for now. there is change inside what maybe break it. please try also v2 with the USB port

Just did Portisch. Version 2 detects my USB flash drive!!! :))))

… Also my cell phone lit up and without a charging error (exclamation mark), and seems to be charging ! :slight_smile:

Ok, the port type is wrong set to host, it needs to be otg. Thanks for testing.

1 Like

Great, version 2 works. Can i use it too with 19 Nightly?

I will include the patch as soon as possible in the nightly. Right now I am in bed as my back hurts too much :sob:

Thank you very much for your great work.

Thanks Portisch! Also never issue with me testing. When you have time, drop a message when you fixed that Pulse-Eight CEC Adapter error message. Enjoy the sleep, you deserve it! :slight_smile:

the dtbs are for both, Portisch said. :grinning:

@Phant0m @pepek33 here the last test version

g12a_s905x2_beelink_gt1_mini_2g.dtb (66.8 KB)
g12a_s905x2_beelink_gt1_mini_4g.dtb (66.8 KB)
g12a_s905x2_beelink_gt_mini_a_2g.dtb (66.6 KB)
g12a_s905x2_beelink_gt_mini_a_4g.dtb (66.6 KB)

I saw only a small diff between GT1 mini and GT mini A.
The GT mini A do not have a RTC clock.

And please test if ethernet is still working like before.

For which version of coreelec is the file intended?

doesn’t matter. it’s the same kernel for both

@Portisch Just tested the latest. Both USB ports are functional, and no more start-up message about Pulse-Eight CEC Adapter error. Enabled Ethernet and tested, working good also.

I am now however receiving every-time I reboot CoreELEC a message.

'… update it to resume normal startup.
… startup in 30s… 29, 28, 27, 26 … ’

Just update tomorrow with the new nightly.
The delay happens as the dtb is not found in default folder. It will be solved by itself when updated.