Beelink GT1 Mini & CoreELEC, No USBv2 Port

From 1st view I don’t see usb related difference in android and CE dtb files

I have same issue .(sn: 95X)

Definitely a difference when I’m booted into Android, I have two perfectly functioning ports to be used and just the one functional USB under CoreELEC. Not only am I missing out on the High-Speed USBv3 port, but the convenience that it brings by having two functioning ports.

Also multiple shared issue reported on these forums.

Fresh boot, Paired Bluetooth, Playing music from phone to box, no audio.

(dmesg): http://ix.io/27Sa

(udevadm info /sys/bus/sdio/devices/sdio*): http://ix.io/27Sc

(lsmod): http://ix.io/27Sg

(systemctl status brcmfmac_sdio-firmware-aml.service): http://ix.io/27Si

It’s a shame that we can’t update our own initial posts on these here CoreELEC forums… Because first thing I tried was change USBv2 to USBv3 for title description.

Here’s another problem. Use ’ Suspend ’ TV shuts down, and my box turns off, light goes out.

Press Power button on my box remote, the box lights up. TV however remains turned off. Yet I’m able to shell the box. Noticed doing lsusb -t, only showing hubs nothing else like it always does with the Air-mouse plugged in.

If I start the TV up manually, no HDMI signal. If I try pressing the remote power button, the box doesn’t power down. Also using journalctl -f, unplugging and then re-plugging the remote receiver, doesn’t ever trigger a single event… so there’s no USB ports whenever I resume from ‘Suspend’ plus the TV never comes on when trying.

Hi kevinjhd, thanks.

On another post you said that you have GT1 Mini (Amlogic S905X2 4GB/32GB), mines 4GB/64GB. You also said that you don’t have a working USB v2.0 port. Is it actually USBv2? Are you going by the colour-coded ports? Because with mine, the USBv3 port is the one that doesn’t work, and It’s incorrectly colour-coded, so It’s actually the black port for USBv3.

I’m using Android now, so I’ve forgotten which one doesn’t work, USB2.0 or USB3.0. Anyway, one can’t be used.
But in 9.2, I remember that both USB2.0 and USB3,0 worked.

I started off on CoreELEC 9.2.1, and it hadn’t worked with the public release. I switched to the Nightly builds and still testing with those. Maybe CoreELEC 9.2.0 worked, 9.2.1 broke support again?

I think the failure one is Usb3.0(blue colour)。I use it(Usb3.0) to connect my hardisk,and the system do not dentify it。
(I use Usb2.0 to connect the remote control)

Tried CoreELEC 9.2.0, except for the green screen, I see no difference. USB v3 (black-coloured) USB port still not function.

Back to my normal CoreELEC setup and anyways the Bluetooth works but I done some things. It might have worked but I was expecting CoreELEC to use TV speakers. I had to go into Kodi settings and change Audio to use just the Bluetooth headset / speaker. Noticed that It cuts out badly while just on the Bluetooth section (CoreELEC \ Bluetooth), that shouldn’t be… This design seems like a hassle to use Bluetooth, even if it’s not often.

@TheCoolest can you maybe contact Beelink and ask them what changes them for the kernel changes for this device?

I have seen USB related changes in Beelink source code dumps before.

1 Like

Hi boot2k3. Nothing to report I imagine? Clueless?

Just really like CoreELEC, but seems no support. At least for my unit, so.

Thanks boot2k3 for giving it a shot.

No, I didn’t find nothing interesting in dtb. It looks almost the same as we have for usb part.
May be we receive some info from beelink later…

Thanks. They have the holiday that lasts to the 30th, so It’ll be Sunday evening I think, be the soonest. Hopefully this issue can be figured out, really like CoreELEC, and want to use. However its disappointing that It’s at a price, that being I loose my High-Speed USBv3 port.

Anyways be looking forward to seeing word back, thanks boot2k3.

Statements like this are not helpful, I have asked another developer to contact the manufacturer, if you persist then I will close this thread and then you really will receive no support.

We are dealing with a lot of other issues and there is an imminent major kernel update we are working on so have some patience for Christ sake, you do not need to create as many posts for this single issue as you have.

1 Like

adamg, you misunderstood me. I wasn’t talking about no support on the issue, because clearly there have been. I was in reference to hardware supported, so please accept my deepest apologies for the way that shown, because I can see where that can be taking wrongly.

Also, I only created so many posts to help troubleshoot and narrow things, down, am I wrong to be doing this on the CoreELEC forums?

There was a change with Beelink FW update regrading what really caused this issue. With 002P0 release both USB’s were still working with CE, after that and even in the newest 005P0 one of the USB port came to be unusable. So something main has definitely changed between those FW’s (in the bootloader maybe?)and what I thin that’s worth to compare and revisit. I’m still wondering if CE team could resolve this issue somehow. Any hope for this in the future?

Any news on this issue? There’s a new stable CE and also a newer official Android FW came out for the Gt1-mini since recently. Anyone had a try with checking on them?

About | FAQ | Terms of Service | Privacy Policy | Legal Notice