Blacklisting meson ir not working since v9.0

A few months ago I did the following to disable IR on my KIII Pro… echo “blacklist meson-ir” >> /storage/.config/modprobe.d/blacklist.conf

I have a few CoreELEC boxes and the KIII Pro is my TV server which kept powering off when I powered off another CoreELEC box so I disabled IR altogether. It has worked fine for ages.

Since the v9.0 upgrade however the IR is working again and I cant disable it. I checked the blacklist.conf file and “blacklist meson-ir” is still in there but seems to be ignored.

Have you tried delete remote.conf in /storage/.config and reboot?

I’m trying to diable the IR in my TX92 running CE 9.0.0 and I tried adding

options dvb-usb disable_rc_polling=1

to the file /storage/.config/modprobe.d/dvb-usb-disable-ir.conf

and that does not work either.

EDIT: I have no remote.conf in /storage/.config

Try creating an empty file called remote.disable in your /storage/.config directory.

The easiest way to do this is to login via ssh and use the following command.

touch /storage/.config/remote.disable

The presence of this file indicates to the remote configuration system that you would like to disable the meson-ir and amremote IR drivers.


This worked just great, thank you.

Perfect. Thanks very much!