Blank screen while trying to install CoreELEC 8.95.7


#1

Hello All,

Issue: Blank screen while trying to install CoreELEC 8.95.7 thus cannot complete the installation. Essentially AMLOGIC S905X logo displays on the screen and then Blank Screen. The Blue light in this TV Box remains lit.

My TV box is connected via HDMI cable to my TV (not 4K). I have tried on an external monitor with a different HDMI cable. Same result.

dtb used - gxl_p212_1g.dtb, gxl_p212_1g_g9sx.dtb

I have burned the sd card with rufus and used the following adb command to initiate the booting from sd card:

C:\opt\adb>adb.exe devices
List of devices attached
192.168.1.246:5555      device
C:\opt\adb>adb reboot update

Note that I am running CoreELEC in 2 other boxes thus familiar with the installation process.

My device: https://www.docooler.com/p-v1880eu-16g.html
Desc: Docooler M9S-PRO Smart Android TV Box Android 6.0 Amlogic S905X Quad Core UHD 4K 2G / 16G Mini PC WiFi H.265 VP9 DLNA Miracast HD Media Player EU Plug

What is NOT working:

  • Cannot install CoreELEC (same issue with LibreELEC)
    (dtb used: - gxl_p212_1g.dtb, gxl_p212_1g_g9sx.dtb)

What is working:

  • It runs Stock rom “build_hx_s905x_Nougat_256x4_528m_20171030_1134_ZNT_2017110107”
  • It runs armbian debian stretch from SD card. (image: Armbian_5.68_Aml-s9xxx_Debian_stretch_default_4.19.13_desktop_20190110.img)
    dtb used - meson-gxl-s905x-p212.dtb

I know this box has 1GB of ram and NOT 2GB as advertised.

Hardware and dmesg info is here:
https://pastebin.com/FYXzuEE8

Image of the chips on the PCB board is here:

I have adb root shell connectivity and armbian ssh root access. Let me know if I can provide more information.

Kind regards
Hannah


#2

Hello All,

Can I provide any more relevant info to get further assistance in this regard please?
I wish if I could get some more guidance.

Kind regards
Hannah


#3

I’ve searched a bit and found many complains about this device not working with any JeOS.
Only one guy at freaktab managed to install LE on it (the procedure should be the same for CE).
Unfortunately he didn’t go into any detail.
Maybe you could ask him, what he did to let it boot LE.


#4

Thanks for your effort.Appreciate the link.