Bluetooth adapter not recognised


I have just setup a new N2 box with latest 9.2.1. I have a problem with my bluetooth adapter not showing in coreelec, when I go to bluetooth devices there is nothing listed yet lsusb shows the adatper?
Bus 001 Device 003: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

Which Bluetooth devices have you tried to pair / connect with your N2?

Just in the case this is a misunderstanding about how the Bluetooth Settings work in CoreELEC. The Bluetooth section of the CoreELEC settings won’t show the USB Bluetooth adapter itself, but should show any Bluetooth devices that are currently discoverable or have been paired / trusted in the past.

I am trying to pair the N2 with a Harmony Hub. The Bluetooth section just says no bluetooth adapter found. Is there a pairing step that I need to do?

I’m having trouble with a BT USB dongle as well using a Cambridge Silicon chip.

See: Bluetooth dongle not working on A95X BN7

Perhaps one of us will get an answer.


After going through 3 different adapters from Amazon, the Asus BT400 worked perfectly out of the box.
The BT400 uses a Broadcom chip.