Boot error, hangs. " Starting debugging shell for boot step: mount_flash...type exit to quit ### "


#1

Upon imaging in Win7 via Etcher or Win32DiskImager, then inserting the USB stick into TV Box, I keep getting above error on top of blank screen. No boot.

I have tried with several LibreElec /CoreElec Leia beta/RCs on my X96mini S905W box, that already has a CoreElec 8.95.6 internally installed (and booting/working fine.)

I have been online to see many similar error reports, usually for RPi @openelec. So what is a solution?

First time sometimes, the same USB stick/SD card works normally. Have 16GB SanDisk Cruizer and 8/16 SanDisk/ Samsung SD cards I use with a USB adapter.

But seems after a couple of boot attempts, above error happens no matter how many reformats under Windows diskpart or Ubuntu gparted etc. Or starting with fresh installs from Etcher/ Win32DiskImager.

Under Windows I am unable to see the boot partition on USB stick after the boot attempts, but Ubuntu gparted /fdisk shows both fat32 boot and ext4 storage partitions without any error reports.


#2

This error happens because you have attempted to install LE over CE or vice-versa.


#3

I see.

  1. So if I install only CE over CE, this mount_flash error should go away?

  2. If I start fresh meaning I have Android in internal memory as usual but only boot from CE or LE SD card/USB stick one at a time, this error shouldn’t occur?


#4

In short yes


#5

@adamg

This isn’t solved at all !

I took your 8.95.7 and burned via Win32DiskImager on a fresh USB stick to get the same mount_flash error on a new X96mini 1/8 G TV box. So this has nothing to do with LE over CE.

Otoh, an 8GB SD card instead of the USB stick works fine so far.


#6

That means it’s a problem with your USB stick and/or box refusing to boot properly from the USB stick.


#7

None of our guides recommend using Etcher or Win32DiskImager, try using Rufus.

Either you are doing something wrong or your USB stick is goosed and I have to say this is becoming a bit of a repeat occurrence now with you always having some issue or another.

USB sticks work fine for me and I prefer using them rather than SD-card’s as I have a couple of really fast ones.