Boot usb/Dualboot Ugoos AM7

Hello everyone. First thank you to the team for everything. I use coreelec since years and it’s always been easy to use and without big problems. I just purchased a new device (ugoos am7) thanks to s905x4 chipset being supported. I am familiar with booting from an sd card but there isn’t a sd slot. Can i simply boot with a usb stick? I read that it’s also possible to dualboot coreelec with android on ugoos devices. Can i do this myself or do i need to wait for ugoos to release a dualboot firmware with coreelec? Thanks in avance and keep going.

You can boot from USB:
https://wiki.coreelec.org/coreelec:ugoos

1 Like

Thank you!

Hi again, i tried a bunch of times to boot from all usb ports while using the toothpick method. Both pushing on “reset” or “update” toothpick buttons. It boots normally or boot to bootloader. So if anyone can help me figure out which usb port i must use and the good method that would be great.
Thanks

thank god i thought i was the only one. i’m trying too make coreelec work on my AM7 for days but it won’t work… i think maybe the only bootable usb port is the usb-c (otg) one. As soon as i buy a usb-c stick i’m trying. Too bad they didn’t add a sd slot, probably not enough space lol

1 Like

I burned CoreELEC 19.5 RC2 to a 32 Gb Sandisk Ultra Fit using USB Imager, added the correct .dtb from the device tree folder, saved Ugoos UR-01 remote.conf from the remotes repository, inserted the USB Drive into the USB 2.0 port (that’s the black one), powered on the AM7, and it boots from USB into CoreELEC.

From there I am able to reboot to Android. From Android I am able to reboot to CoreELEC from the terminal (or with reboot to *elec app).

Android firmware installed on Ugoos AM7: 1.0.7.

If the reset button method doesn’t work, try the terminal method (see here for all possible boot combinations)

Device powered via USB-C

Log

Please let me know which method works for you.

1 Like

For AM7 you will need to enable superuser in device settings in Android.
After a reboot open the new APP Magisk.
Insert USB media with CoreELEC on it and place dtb.img.
Install the APP Reboot to LibreELEC and run update, Magisk will pop up and select yes to allow root access. After the reboot it should boot into CoreELEC.

1 Like

Thanks to both of the person from the team. I finally found the problem. I was on the latest firmware 1.1.0. I downgraded to 1.0.7 and boom it worked. Weird i think i saw in the changelog for CE-20 alpha 3 that the latest firmware was supported. Well it works now thank you to everyone.