Cannot complete installation on new box (S905X3)


Needed a 2nd box in the house so picked up this one.

Having used Coreelec on my first box, I wanted to use the same on this second one. I have created a SD card with the generic S905X3 build. I tried using the obvious dtb files, but the furthest I get is the Coreelec configuration screen (i.e. choose your language). The trouble is that I cannot go any further as the remote will not work.

Any advice please?


Plug in a USB keyboard to configure CoreELEC.
Then look at the instructions for setting up a remote on the forum. You will find a repository for remote files. Select and copy the nescessary files over either via SSH or by browsing the SMB share on your device.

You can use Yatse on your phone if you have an Android device.
But the easiest way is to connect a keyboard or mouse, as mentioned above.

You could download a working amlogic remote control file from the repository and save it to the root of the USB Flash Drive or SD Card.

The one for NexBox A95X should work with your remote.

Thanks. Got the initial configuration complete by using a keyboard. Still can’t get the remote to work. I have downloaded the NexBox A95X zip. I found the amlogic remote control file (remote.conf) in the LibreElec directory (confusing the CoreElec directory had the Meson IR files) and I have copied it to the root of the SD card (/storage) and to /storage/.config. I have rebooted the box, but still have no response to the remote.

All you need is to copy the remote.conf file to the root of the SD Card (where the dtb.img is). Upon restarting, CoreELEC should reboot once to accept the remote configuration, after which your remote should work. If you already committed CoreELEC to nand (installtointernal), then the remote.conf file goes into /storage/.config

There are detailed installation instructions in the library section of the repository.

Still couldn’t get it to work. Came up with another idea. My previous box was a Sunvell T95M, so grabbed the remote.conf for the T95Z. Re started the new box and it worked with the old remote. As my universal remote is programmed for the Sunvell - problem solved! Many thanks everyone for your help.

1 Like