Can't install CoreELEC 19.0 to eMMC on LePotato

I have a LePotato 1GB. I’ve installed the latest CoreELEC 19 Matrix build onto the microsd card. I’m now trying to push it over to the EMMC.

I’ve tried the following commands:
Starting CoreELEC eMMC installation tool…
System is not supported: gxl_p212_1g_lepotato!

This script is only for Odroid N2. It won’t work on other devices!

-sh: lepotatotoemmc: not found

It looks like the le potato has been excluded from working with the ceemmc command and the lepotatoemmc command has been removed from the software or has been renamed. The last time i had this issue i had to install a non -ng build do the lepotatotoemmc command and then install the -ng tar on top of the non ng build but i don’t want to have to do that between versions of coreelec. Any help on this issue would be great.

It was not ported to CE19. It would probably work but it isn’t implemented. The way it could work is installing 9.2.6 to emmc then do a tar update.

What exactly wasn’t ported to CE19?

I’ve also gone and used this command:
ceemmc -x
y (to continue with no official support)
and then I get the following output
“eMMC size: 0x0001d2000000 [8GB]
Partition ‘/dev/reserved’ does not exist!
Failed to read original partition table!”

Maybe there is a way to install this way but I’m just not understanding the error message.

Are there any major downsides to installing CE9.2.6 to emmc and then upgrading to CE19-ng build using .tar file? My only concern is there would be a bunch of leftover files and such. But I’m not sure if that would impact the stability.

I use my kodi dir since Dharma times iirc and I have always upgraded. The upgrade from 9.2 to 19 is tricky because of the python3 move so some addons might not be available anymore. It still worked for me. There will be no leftover files.

I still think it’d be advantageous to some if they can just do a complete clean install incase jumping from a non -ng build to an -ng build as well as going from CE9.2 to CE19.0 has any detrimental effects.

I think I’ve successfully migrated from the SD to the emmc. I’m not an expert on this though and so maybe someone with more experience can check a few things.

I took the file “lepotatotoemmc” from here: “” and moved it to the lepotato using winscp.

In putty I used the following command “chmod 775 /storage/lepotatotoemmc” to give it the ability to run the script.

I ran the script using putty and got an error about “proc/device-tree/le-dt-id” not existing. I ended up going to the directory to find that it’s been renamed to “proc/device-tree/coreelec-dt-id” so I fixed this in the lepotatotoemmc script.

I then ran lepotatotoemmc like normal and it seems to be working as intended… somewhat. Some of the problems that I noticed is that it doesn’t produce the splash image with the 30 second count down. It just has a blank screen. This is just cosmetic and it still seems to work. The other thing I noticed is that it didn’t seem to completely wipe the emmc. it still asked if I wanted to enable and disable my previous addons. Maybe this is intended. or maybe there needs to be a selection for a hard reset or clean install. or another script called lepotatotoemmcclean or something. I ended up just running a hard reset on the emmc through coreelec -> system -> reset coreelec to defaults and then I ran the lepotatotoemmc script again to make sure I had a completely clean install. I’m sure this can be implemented easily enough; however, I don’t really have the know how to navigate github or the programming side of things.

I am impressed. You did go all the way. The script was and is a hack to work around the Problem that LibreTech never added a way or adapter to fladh the emmc. Hardkernel has adapters to do this.

Anway the method of hot plugging the emmc is very risky to break the emmc or the board so it’s obsolete.
I am still proud you managed to do all of it by backporting the script. Good job.

Yeah I tried to figure out a way to get it to show up in amlogics usb burn tool. But i couldn’t get it to show up. Figured that it was a lost cause even if I could get the software to see the EMMC my guess is the CE19 image is probably not set up to partition the emmc correctly through the burn tool. I can see how the hotplugging of the emmc is risky. I suppose no risk no gain. I wish i could get the usb a to usb a method to work as it would make it a pretty great deal. they have 8gb emmc modules that comes with the usb a to usb a cable for 10 bucks on amazon.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.