Can't install Widevine

I’m new to this forum and CoreElec in general so firstly a quick hi to everyone!
I’m an experienced Kodi user with many years experience in Windows-based IT support, so while I have very little knowledge of Linux or Android, I’m not a complete stranger to command-line tools and the like.

I was recently given an EgoIggo S95X-Pro (Amlogic S905X 2GB p212) Android box and thought I’d give it a try as it would be nice to free-up the PC. It’s running the ancient original stock firmware (Marshmallow 6.0.1) and with hardly any info available online for this box I haven’t risked trying to flash anything as I’m not entirely sure what to firmware to use. The only post that seemed to have the right model info wanted to send me to a chinese file hosting site where you must live in china to be able to register or access anything, there were instructions for installing and running a browser script to get around this but must be outdated as it doesn’t work.

I didn’t want to brick the box so I resigned myself to using 6.0.1 and installed Kodi (19.1) and all my addons. Everything worked fine except some 1080 streams wouldn’t work and I also had stuttering video problems streaming live tv from my mediaportal server. Someone in the Kodi forum suggested trying CoreElec and here I am!

I downloaded and setup the ng build onto a usb stick which instantly fixed the stuttering in mediaportal pvr, it also runs much quicker than kodi on the android os. The problems started when I tried to use an addon that requires widevine; I accepted the eula, then it says it has to download a gig of chrome os image. I click yes to download (I’ve tried both builds this offers with the same outcome) and it starts downloading. When the progress bar gets about two-thirds across the box freezes for a few seconds before completely resetting and starting to reboot.

I also tried using ceemmc to install to the emmc as dual-boot but it failed saying it couldn’t write the partition table. Having searched the forum, the problem seems to be caused by the Android firmware being too old, bringing me back to the firmware update issue.

I realise that the ideal solution to everything is to buy a new box but that’s not an option right now - I don’t have the funds and even if I did, I want to test-drive the whole set-top-box solution before I commit to buying new hardware.

Installing CoreElec to the internal emmc is not essential but widevine is, can anyone please point me in the right direction as to either how to fix the widevine install issue OR where to download the correct firmware for my EgoIggo?
Current firmware build is:
p212-userdebug 6.0.1 MHC19J 20170420 test-keys

Thanks in advance :slight_smile:

Minimum Android 7.1 is required for Amlogic-ng. Update the firmware and try again.

As I previously stated, I have been unable to find an updated firmware that could be confirmed as the correct firmware for my box so as not to brick the device.
The only info I could find that specifically mentions the EgoIggo then tries to send me to a chinese download site (baidu) that will only let you see anything if you register using a chinese landline phone number which I am unlikely to get installed here in the UK anytime soon.
I would gladly update the firmware if I knew where to find it :slight_smile:

Then invest again €30 for a S905X3 device and you are able to use Amlogic-ng with all features. Or feel free to stay with Amlogic 3.14 kernel.

To be honest, what you kind of support you expect for such Chinese cheap box? Also the SoC is 5 generations back from current newest SoC.

Did you read ANY of my original post at all?
I explained that I don’t have the funds to do that right now and even if I did, I want to test-drive using an android box before I commit to spending money I don’t have on hardware I might not even want.

From what I can see on Amazon and ebay, pretty much every box on the market is a “cheap chinese box” - another good reason not to throw money away buying a newer box that might have just as many problems, particularly if the only support available basically tells you to buy something or go away!

Yes, that’s it. You also not get support anymore for Windows XP, isn’t it? So how you expect support from a non profit organization for such old hardware/software?

You’re unlikely to find an Android 7.1 firmware specifically for that box, as it likely doesn’t even exist.

If you want to update the firmware you’re going to have to take a leap of faith and install one of the generic Android firmwares that install to a wide array of Generic S905X boxes, either ATVxperience or Aidan’s ROM:

There is also this Android 7.1.2 ROM for a Tanix TX7 that seems to install to a number devices besides that model.

Will they work on your specific device? I couldn’t honestly say. Like I said, you’re going to have to take a leap of faith and experiment and be prepared for failure if you want to bring that S905x box up to being able to handle CE19.

Windows XP is 20 years old, this box was bought about 3 years ago.
I wasn’t “expecting support”, I thought this was a public forum where other users can answer questions and offer help to people in need.

You could have simply explained that the Instructions in the download helper haven’t been updated to say that it automatically defaults to the ng build now, unless you click legacy download on the previous page
If you didn’t want to help at all (or even read the original post) you could have just not replied and left the question for someone else to answer. There was no need for the rude, flippant attitude. Is this how all new members get welcomed?

Thank you, that’s a big help!
Despite being a newbie, I only need a few simple pointers like this to get on the right track. Such a shame that others would prefer try to offend me than to be of any help.
Thanks for not being “that guy” :slight_smile:

Maybe you do not read everything?
The answer is:

When you do not find a newer firmware for your device, and don’t ask and use CoreELEC team members free time to request support for a device we have seen this right now the first time.
Ask the vendor for help, they got some of the money you spent on it.

Also we are not the reason that you have bought obsolete hardware 3 years ago, it’s your fault.
By cheap, by twice.

No worries.

I’ve been limping along my X96 S905X for quite some time, though now mostly just to see if I can.

In the spirit of defusing this particular thread, I’ll mention that updating older boxes to newer, generic, Android ROMs is out of the scope of support for the Developers, who are busy dealing with CE specific issues. Luckily, there is a wealth of information on this whole process scattered throughout this forum. Many users have undergone what you’re trying to do but, unfortunately for new members it usually gets discussed in thread topics that describe a specific error, but not the real problem. This thread’s topic as an example.

If I find myself with some time, I’d like to create a more comprehensive, well labeled thread with a summary of options, etc so people have a dedicated source to arrive at on the topic. Hopefully I find the time to get around to doing it.

I already said in the original post that you didn’t read that I had already worked out that I needed newer firmware and I had already seen the post you’re saying is the answer. It isn’t the answer, it is the question - what to do to move forward.
The answer for now is to use the non-ng build, which I would have downloaded in the first place if the “Download helper” had clearer instructions.

THAT is the answer and you could have simply told me that ff you had spent as much time reading my original post as you did trying to offend me and ridicule the hardware I was GIVEN and therefore had zero choice over.

Ok, then all is clear. Use non Amlogic build as you were lucky to find the legacy downloads on our web site. Problem solved, thank you.