CE stuck on "MxqPro" screen


I am trying to move from LE to CE (in order to run Kodi 18). My MXQ Pro (S905) was happily running LE from an SD card - LibreELEC-S905.arm-8.2-

I burnt a new SD from CoreELEC-Amlogic.arm-9.2.3-Generic.img and copied the DTB file to root (LE was booting with the gxbb_p201.dtb file, so I copied that. Also tried p200).

Rebooting (or running “reboot upgrade”) results in the box freezing with the large outline font logo: MxqPro.

I also tried upgrading my working LE by copying the .tar file to the Update directory and rebooting - same result - the box hangs with the logo on screen.

Does anyone have any ideas how to fix this?


Recover your device by an vendor Android image and try again.

my device already boots Android without the SD inserted. Is that what you’re referring to?
I assume CE boots similar to LE - I boot into Android (with SD removed), insert the SD, open a terminal and run “reboot upgrade”.
This works for LE, just not CE (which hangs). As did an upgrade of LE.

No, once you install LE on your box you have to re-flash Android to be able to install CE.
The reason is a different u-boot that was flashed to your box with LE installation.
CE installation needs original u-boot that comes with Android…

Ah excellent. I wasn’t aware of that.
So the new LE bootloader is what currently allows me to insert an SD and boot LE, or leave it out and boot Android?
Any advice on how to restore the original loader? This is obviously not my area of expertise :slight_smile:
As I mentioned I can boot Android, and drop into “reboot recovery” if any of that might help.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.