CoreELEC 19.1-Matrix_rc1 Discussion

Please use this thread for general 19.1-Matrix_rc1 discussion

Khadas VIM3l users

Please be sure you have a file /flash/dtb.img on your current eMMC installation before upgrade to CoreELEC-19-Matrix! Otherwise the device will stop booting and a recovery will be needed!

Open a SSH connection and check it by:

CoreELEC:~ # ls /flash/dtb.img

If the output look like this the system is compatible and can be upgraded to CoreELEC-19-Matrix. If you get a “file not found” please restore your system like with a Android image or a compatible krescue image before upgrade! Please keep in mind the VIM3L HTPC kit is including a not official image by Team CoreELEC so maybe it does not support the upgrade as well.


Black screen after RC1 update (N2 -> Yamaha amp -> LG B8).


I tried the 23rd and 22nd nightly, same issue. Where can I get older nightlies or the CE 19.0 tar? Thanks.

EDIT: as suspected, when I bypass the amp, no problem! But still, please point me to older files so I can try and pinpoint the version from which the incompatibility starts.

try a static disp_cap.

My disp_cap from booting connected directly to the TV looks like this:

disp_cap - click to expand

What is the asterisk? Also, I believe I have my CE UI set to 23.98hz so looks like I’ll need to add that?

Can I change UI hz via ssh?

EDIT: I see elsewhere, in relation to disp_cap, kszaq says “Fractional refresh rates are set automatically on Amlogic when needed. E.g. when you play 23.976fps video and have 24Hz refresh rate set, the driver will automatically switch to 23.976Hz.”

(N.b. I have my UI set to 23.98hz because otherwise there is an annoying audio blip about a second after starting most movies/tvshows if a refresh rate change occurs. Even when I set the delay on refresh rate change to really high settings like 5+ seconds.)

Don’t mind the asterisk. Just use the disp_cap

Now to test via amp… didn’t help, black screen still.

I was about to downgrade to 19.0, but when I turned on the TV and amp I noticed that 19.1 was displaying via the amp! :slight_smile: I double checked in system settings, definitely RC1. I took logs:

I’ve since downgraded to 19.0 anyway, as I rebooted forgetting to delete the update file… let’s update back to RC1 and see what happens… damn, black screen after hardkernel logo again. :frowning: (via amp)

:sparkles:SOLUTION: After booting, turn TV off then on. We have picture via amp with CE19.1 RC1! :slight_smile: then…

  • Next reboot (1): CE logo displays (pulsing… is that normal?) then UI displays normally, no need to turn TV off/on.
  • Next reboot (2): black screen (turning TV off/on fixes it, once more)
  • Next reboot (3): black screen (turning TV off/on fixes it, once more)

My kit N2, Philips 50" (6754) and Pioneer VSX934.
Did a fresh install from scratch and Video is noticabily smoother with auto switching frame rates fine at default settings. Audio up to Atmos/DTX works great as does Bluetooth audio. Only hiccup is that with a 5 minute clip of Alita with HDR10+ (from my UHD disk) picture and sound breaks up/stutters but another clip from ‘Bad times at the EL Royal’ (HDR10+) is fine. (Every version after 9.25 does the same).
Nearly a Keeper!

1 Like

Thanks for update team.

Still CE settings error at boot, possible troublesome add-ons is Multi Weather and Composite, uninstalling them is not a longtime solution I think.

Kodi log


This error is known, switch to english till it’s solved.
What language you using now?

I was seeing that issue after trying to update from 9.2.x. It was fixed by performing a fresh install. I use Composite every day & it’s not a problematic addon for me.


Then do what @FXB78 says. Make a fresh clean install and check after every installed addon when it stops working.

I have also used over a year now with no problem I lean more to Multi weather addon be issue since the first time I saw this was after installing that. I did a clean install a month ago when updating to Matrix it will take hours setting everything up again.

Kodi 19 is python3 only, so you need to find which addon is not python3 compatible and go to the addon developer, thank you!

Everything went well on Vontar X3. But, I can see it’s rc1, while I’m on stable channel. Is that some kind of dev build? Or stable line still.

That sounds like problem like I have. TV Philips, Odroid N2 and non working HDR10 video that work on 9.2.5. I am staying on CE9.2.5.

Silly question… Is the new color scheme just for the rc or will it be used going forward?

It’s the new colour adopted by CoreELEC. You can change it of course!

About | FAQ | Terms of Service | Privacy Policy | Legal Notice