CoreELEC 19.1-Matrix_rc1 Discussion

Great work on Matrix, it’s very stable and Kodi crashes less often on daily use.

Using Mecool KI Pro as a daily driver. I was wondering if there is some way to install CoreELEC on eMMC on KI PRO? Currently, ceemmc doesn’t do anything.
Here’s the output:

ceemmc -x
Starting CoreELEC eMMC installation tool...

System is not supported: gxl_p230_k1_pro!

There is NO official support by Team CoreELEC
if you continue to run this tool!
Continue? [y]: y

eMMC size: 0x00039d000000 [16GB]

No CoreELEC installation found on eMMC

Install in dual boot mode, CoreELEC and Android on eMMC
  Use CoreELEC data from
    [1] current used SD or USB device
    [2] existing backup on current used SD or USB device

Install in single boot mode not possible!
  No DT partition was found

Please choose one option? [1/2]: 1


Is there a firmware upgrade or something I can do to install it on eMMC or is it considered too old for this feature?

I have on second device KI Pro on emmc with Coreelec 9.2.7, some one year. I installed 9.2 and after from release to release was updared during time.

This is a bug, please use last available nightly.

1 Like

Thank you very much! It is working now!

Hi, 19.1-Matrix_rc1 working beautifully on my K1pro, except for remote, which is dead. Used to work on 9.2.7. Any idea? Thanks

Maybe battery are dead? Just joking.

What did you do to get it running? There are some differences mentioned for CoreELEC 19 here (toml extension): How to configure IR remote control

If someone is interested, installing CE on the internal mmc, the second system using the standard ceemmc utility.
Only for NG devices!
In principle, there is nothing complicated. Everything is done in SSH, I used a smartphone with Terminus installed for this.
The only limitation is that almost all TV boxes are not officially supported, so the command must be run with option -x:

ceemmc -x

Installed on the available X96Max and Mecool Ki pro. They also had a stable RC1 Matrix build installed on an SD-card. With X96Max, there were no problems at all, the configured system flew into the internal memory in parallel with android and loading from the sd-card became unnecessary, and for some reason there were problems with Ki pro and the installation gave Aborted! Then for the sake of laughter, I decided to try to update to a fresh nightly build and the installation was successful. It can be noted that emmc is faster than sd in terms of reading speed, so loading both the system and all add-ons has become more fun. Good luck to everyone…

Hello, since I had problem trying to do an upgrade from 9.2.6 to Matrix V19, but wanted to keep all the customizations I did on the Aero Silvo Nox skin on the previous installation, I finally did a clean install on an 8 Gb MicroSD card, keeping the older 9.2.6 (now 9.2.7) on the eMMC card of the Odroid N2 to revert to if things went bad.

I took the advice of “thecubasekid” on the previous V19 Matrix topic and copied the Nox files and skin shortcuts from adons and addon_data, and everything ended up perfect, so thanks to thecubasekid for the tip. I finalized the setup the way I wanted, made a backup of the microSD card and restored that on the eMMC. Everything is fine, so I’m a happy camper.

Only thing is that the microSD card was a 8 Gb, but the eMMC is a 16Gb; so I have almost half of the eMMC that is not used. Checked to see what is the command I could send from ssh to expand the partition so that it uses all the available space on the eMMC, but I’m not sure of the correct command to do it. I know when installing fresh the image on the card, that command is lauched at the first boot, but I can’t find the way to lauch it afterward the way I did. Thanks

Can’t you simply make a complete backup of your present eMMC installation, then make a fresh installation on eMMC, which will be properly resized, and then restore your saved backup?

:blush: Why didn’t I think of that… Yup sure could; thanks for the reminder, Sholander !

Try please install default controller. I had from oldest release on device but was not marked as installed, but do it all ok. After try reinstall on on 1.0.8 is not installed:Add-on:Default Controller - Official Kodi Wiki

I have a problem after removing the SD media the boot returns to android!
Tell me where is the error?

    indent preformatted text by 4 spaceslogin as: root
root@192.XXX.X.XXX's password:
#                  CoreELEC                  #
#              #

CoreELEC (community): 19.1-Matrix_devel_20210402005658 (Amlogic-ng.arm)
CoreELEC:~ # cemmc-x
-sh: cemmc-x: not found
CoreELEC:~ # ceemmc -x

Starting CoreELEC eMMC installation tool...

System is not supported: gxl_p230_k1_pro!

There is NO official support by Team CoreELEC
if you continue to run this tool!
Continue? [y]: y

There is NO official support...
Just do not use the tool on this device…

My a95x max box upgraded to rc1 yesterday…will that’s what happens when you have automatic update set :slight_smile:
So far all good - had to remap the ir remote, but there is good detailed help on the web :slight_smile:

So far only one issue, boot with monitor off, and it’s impossible to get the screen on again. Didn’t happen with previously release. Not necessarily a problem as I run it headless most of the time and control via hhtp/kore and “mess” with it using ssh and sometimes need the screen

great job

That’s a common problem. Good News is, there is a workaround.

Look here:

But why? This tool fine working on ki pro, only on official realise RC1 was error “Aborted”, but last nightly build all done without errors and working perfectly…

Perhaps install last nightly
cd .update
move to interlal
ceemmc -x
after this
return RC1
cd .update

1 Like

There’s no official support for no supported devices but if you read some posts above yours you can see there was a bug that was addressed in the nightlies.

1 Like


i’ve updated from 9.2.7 to 19.1 rc1 and my smb shares stopped to work.
It seems like the dns resolving does not work.

INFO <general>: VideoPlayer::OpenFile: smb://SERVER2008/BluRays/***.mkv
2021-04-05 17:33:29.122 T:4848     INFO <general>: Creating InputStream
2021-04-05 17:33:31.217 T:4788     INFO <general>: SMBFile->Open: Unable to open file : ' 
unix_err:'6e' error : 'Connection timed out'

IP of server is, and can be pinged via ssh without error using hostname.

Tried to change min/max smb version in smb-client options, but no success.
Any suggestions?

It’s recommended to make a clean install.

Already tried clean install, using my “old” sources.xml. Same problem.
Clean install using IP instead of hostname in sources.xml works, but not willing to rebuild my whole sql database at the moment.
Will go back to 9.2.7