CoreELEC 19.4-Matrix_rc2 Discussion

Please use this thread for general 19.4-Matrix_rc1 discussion

1 Like

IC+ 1001M is also supported now? Thx.

Cani ask about change of nfs timeout to 30s. What was it before, and what does the change improve/fix?

It is this PR:

1 Like
  • m_nfsTimeout = 5;
  • m_nfsTimeout = 30;

This wil help :wink: I was planning on switching to NFS, so great timing !


Intereating, i was using nfs connection with a NAS, and someetimes i faced an issue where eg watching a half hour show, half way the player would just stop. All i had to do was immediately press play and after 3 seconds it would continue from where it stopped.
It was too small an issue to investigate, but wondering if this might be related/might solve?

Yep, it’s related if you use NFS.
NFS had very low timeout for some HDD’s by default.
For samba it could be also configured if required.
More details in samba and network(for nfs) section:

Hi all

I run CE for many years now and one of my current devices is a [S922X] Bee-link GT King running from EMMC. Basically I never had any problems so congratulations and thanks for the software!

Until an hour ago I ran 19.3 and I put CoreELEC-Amlogic-ng.arm-19.4-Matrix_rc1.tar in .update just as usual (md5sum 0a8f3b16ab82620287d1414596ea3607)

… but the update fails … I see on console:

'### Starting debugging shell for boot step: mount_flash... type exit to quit ###'
'*** Error in mount_flash: mount_common: Could not mount LABEL=CE_FLASH ***'

What would be the problem? and, How shall I best proceed trying to recover ?

(I have not tried, and hesitate, to upgrade a KVIM3L running 19.3)

Thanks a lot and have a nice day


19.4-Matrix_rc1 boots from external SD on the box and ceemmc appears to succeed:

(I have a backup on a server so I can restore)

CoreELEC:~ # ceemmc

Starting CoreELEC eMMC installation tool…

eMMC size: 0x000e67800000 [64GB]

Existing CoreELEC single boot installation found on eMMC

Renew current CoreELEC single boot installation on eMMC
Use CoreELEC data from
[1] current used SD or USB device
[2] existing backup on current used SD or USB device

[3] Make a backup of current CoreELEC single boot installation on eMMC to current used SD or USB device

Please choose one option? [1/2/3]: 1

Usable space of ‘partition CE_FLASH’: 512MB
Used space of ‘/flash’: 229MB

There is enough free space on flash partition on eMMC for installation!

ALL existing CoreELEC data on flash partition on eMMC will be lost!
Continue with [y] or press enter to skip flash partition!
Continue? [y]: y

Starting copying of data to the eMMC!
Please do NOT interrupt this progress till it’s finished!

Copy all data from ‘/flash’ to ‘/media/CE_FLASH’
229.50M 100% 24.32MB/s 0:00:08 (xfr#68, to-chk=0/70)

Synchronize data on disk with memory, please wait…

Usable space of ‘partition CE_STORAGE’: 58388MB
Used space of ‘/storage’: 7MB

There is enough free space on storage partition on eMMC for installation!

ALL existing CoreELEC data on storage partition on eMMC will be lost!
Continue with [y] or press enter to skip storage partition!
Continue? [y]:


Please remove current boot media (SD or USB) and
reboot the device to boot from eMMC!

But still the reboot from eMMC gives same error

Starting debugging shell for boot step: mount_flash… type exit to quit
Error in mount_flash: mount_common: Could not mount LABEL=CE_FLASH

Any hint welcome!


When running from external SD, both /dev/CE_FLASH (= /dev/block/179:7) and /dev/CE_STORAGE (= /dev/block/179:8) from EMMC look just fine and can be mounted and contain the updated 19.4-Matrix_rc1 … I did fsck both partitions which were clean. But still boot from EMMC fails.

Thank you for your report. This looks like a “common” issue, so not directly related to 19.4-Matrix_rc1.
We will come back to you for more information. In meantime please get a USB keyboard you can connect to the device to run some commands in debug boot console, thx.

1 Like

Yes, attach USB keyboard and boot from eMMC. When you see shell # type command dmesg. And make a picture what was written on screen. And then we will proceed with more instructions.

Also when you boot from uSD card can you mount eMMC manually?

mkdir /media/FLASH
mkdir /media/STORAGE

mount /dev/CE_FLASH /media/FLASH
mount /dev/CE_STORAGE /media/STORAGE

umount /media/FLASH
umount /media/STORAGE


And is the label correct?

fatlabel /dev/CE_FLASH
1 Like

@Portisch : thanks a lot for explaining. I will wait to upgrade my (other, a KVIM3L) 19.3 …
I attached USB keyboard but it does not work in the state the GT-King box ends up in attempting to boot 19.4_rc1 from EMMC. A prompt shows but no input can be given. Same USB keyboard works when fully booted into 19.4_rc1 from SD. I will reply to @vpeter post about the LABELs.

Than you might need to try another USB port. It have to be working. MAybe you got a port what get activated by dtb later in boot process.

1 Like

@vpeter thanks for help.

As replied to @Portisch USB keyboard does not respond in the state the box ends up in when booting from EEMMC.

The error message suggests something wrong with the CE_FLASH label indeed.
I can mount flash and storage using device but only storage using label:

CoreGT:~ # ls /media/

CoreGT:~ # fatlabel /dev/CE_FLASH
CoreGT:~ # fatlabel /dev/CE_STORAGE
Logical sector size is zero.

CoreGT:~ # mount LABEL=CE_STORAGE /media/STORAGE
CoreGT:~ # mount LABEL=CE_FLASH /media/FLASH
mount: mounting LABEL=CE_FLASH on /media/FLASH failed: No such file or directory

CoreGT:~ # umount /media/STORAGE
CoreGT:~ # umount /media/FLASH
umount: can’t unmount /media/FLASH: Invalid argument

So probably flash partition label has some issue.

dmesg from when booted from SD does mention the internal partitions 7 and 8 by name:

CoreGT:~ # ls -al /dev/block/ | grep CE_
lrwxrwxrwx 1 root root 11 Jan 12 15:23 179:7 → …/CE_FLASH
lrwxrwxrwx 1 root root 13 Jan 12 15:23 179:8 → …/CE_STORAGE
CoreGT:~ # dmesg | grep CE_
[ 1.002877@0] meson-mmc: [mmcblk0p07] CE_FLASH offset 0x000006400000, size 0x000020000000
[ 1.002962@0] meson-mmc: [mmcblk0p08] CE_STORAGE offset 0x000026400000, size 0x000e41400000

I feel tempted to perhaps label mmcblk0p07 again but I rather wait for expert advice.

Have a nice day!

@Portisch : thanks for follow up. I did try all 3 ports. It happens to be an Apple USB keyboard (my wife is into Apple, I am into Linux) and all keyboards I can try are either Apple USB or Apple BT.
Have a nice day!

If you can’t get into boot prompt when error happen then there is only option to recreate label with command

fatlabel /dev/CE_FLASH CE_FLASH

The worst thing which can happen is to reflash whole device with Android and setup everything from scratch.

1 Like

Thanks @vpeter and @Portisch for expert advice!

CoreGT:~ # fatlabel /dev/CE_FLASH CE_FLASH
CoreGT:~ # fatlabel /dev/CE_FLASH

The box boots again from EEMC!


Sadly the reason will stay unknown. Till next time :slight_smile:

1 Like

I (or someone else) could go through process again if that helps. But I first need to buy an USB keyboard that works… or perhaps having CONFIG_HID_APPLE=y would help?

CoreGT:~ # zcat /proc/config.gz | grep -i CONFIG_HID_APPLE=