CoreELEC 21.0-Omega_alpha1 Amlogic-ne Discussion

OK, thanks for the time.

oops I was late a bit…
nevertheless, I tried dtb v4 on my TanixW2, same result, stuck at boot with moving artifacts.
So I will wait new dtb release then.

my new Homatic Box R 4K Plus will arrive tomorrow.
This box is initially only for testing. My Odroid N2 with Corelec will remain the main system for now.

Maybe someone can answer a few questions, regarding the Homatic, that have already come up:

  1. I hope the “CoreELEC-Amlogic-ne.aarch64-21.0-Omega_alpha1-Generic.img.gz” is the correct file for the Homatic.
    Which dtb file must I use for this device?

  2. I read, that the Homatic does not have an IR Receiver, so I wonder if I will be able to switch the box on with an alternative remote like Logitech Harmony?

Thank you!

  1. As written in other thread it is sc2_s905x4_sei_smb_280.dtb.
  2. Not possible.

Thank you, that was quick!

Sorry, but I didn’t find the other thread. Maybe my search was not good enough.

Is there another way to power up the device? (Flirc, Wake on lan)

Does anyone know if the Rocktek G2 4K has an IR receiver?

Most discussion happens here: Homatics Box R 4K Plus

I don’t know if IR receiver on RockTek G2 exists (I think not) but even if it does (like with Dune version) wake up is not possible.

You need reboot to android, and there sleep the device.
No IR receiver in Rocktek, and Nokia.

From Portisch:
Power consumption Homatics R4 Plus with 5V DC IN:

GUI, idle:		2.9W
AV1:			4.0W
HLG:			3.6W
H264, 1080p:	3.2W
DV 8.1, 4k:		3.9W
DV MEL, 1080p:	3.4W
Power off:		0.12W
Suspend:		0.64W

You can the wake the from suspend by switching to its cec input.

1 Like

Thank you for all your answers.

What is future of s905x3 for now, will it get converted to ne or will it get left behind on ng

Still on may, maybe never.
There are already new SoC on market so nobody interests on old ones.

Confirm using 21.0-Omega_nightly_20230505 with
s4_s905w2_2g_v4.dtb MD5 ce1aa2c1e0c00b6e36615d1b98649b0a
Tanix W2 2+16G can now boot normally and install to emmc fine.

5G wifi still only WPA2, no WPA3 or mixed encryption.

Btw, IR remote both work out of the box in 20.1 and 21.0 without the need for remote.conf, but XB360 joystick is not working in 21.0 for UI control.

Yo tengo tanix tx3 mini+ s905w2 de 4/64 y no me funciona el DTB (s4_s905w2_4g)
de core 20.1 con instalación nueva para core21

He probado coreelec 21 ne con el dtb s4_s905w2_4g.
No me inicia a traves de la tarjeta microsd
qué dtb tengo que usar?
Tengo que usar ng?
o aun no hay dtb?

I have tanix tx3 mini+ s905w2 from 4/64 and the DTB does not work for me (s4_s905w2_4g)
from core 20.1 with fresh install for core21

I have tested coreelec 21 ne with the dtb s4_s905w2_4g. It does not start me through the microsd card
do i have to use ng version?
what dtb do i have to use?
or is there still no dtb?
thank you


1 Like

Check this thread, just discussed the very topic.
U need to use the 21 ne nightly build for the updated s905w2 dtb.

A post was merged into an existing topic: CoreELEC 20.1-Nexus Amlogic-ng Discussion

H96 Max X4 Android 11 Amlogic S905X4 device with 4GB RAM and 100Mbps Ethernet port

CE21NE works great from microSD with DTB sc2_s905x4_4g.dtb file
VFD and Remote also work fine with the files in the repository

Thanks for the awesome NE branch

Vim4 not booting neither of nighties. Stuck on khadas boot logo.
I suppose its somehow refers to hdmi output, cuz it did boot when connected to pc display

Vim4 have a UART header, make a log. I just worked today with vim4, booting fine…

Sorry, im not that advanced to make logs with uart…
Thing is - 20.1 works fine.
21alpha boots fine when using a pc display and installs correctly.
At the same time installed 21alpha doesn’t boot on a regular 1080p tv, as well as setup of 21alpha, which stucks on khadas logo