CoreELEC 21.0-Omega Amlogic-ne Discussion


Please use this thread for general CoreELEC 21.0-Omega Amlogic-ne discussion

Before posting an error please follow these troubleshooting steps.

1 Like

Does this version has player led fix ?

Is it only works with NG version ?

black screen same as in this thread

I set the update channel to Omega. Now the available versions list shows:

  • 21.0-Omeg
  • 21.0-Omega-rc2
  • 21.0-Omega-rc1
  • 21.0-Omega-beta3
  • 21.0-Omega-beta2

If I choose the top one it installs some alpha version instead. Maybe related to the fact it says “Omeg” instead of “Omega” there? Is there some workaround without doing a reinstall?

(If it matters, I’m using Amlogic-ne.aarch64)

Selecting this one works just fine. It’s just the top one (“21.0-Omeg”) that doesn’t work.

I was able to manually update it by doing a wget against the github link of the generic Amlogic-ng tarball, for what it’s worth. Then sticking it in /storage/.update (more specifically running wget within that directory).

It looks like the name Omega did trigger a Python bug.
There is a split(‘.tar’) to remove the file ending but it looks like it remove the ending a as well.

Not sure yet how to solve it…

Do the NE builds have the fixes for “true tv-led” Dolby Vision incorporated yet that are already present in the NG builds?

Same problem for me.
Unfortunately, coreelec didnt boot after update.

Maybe I could help. Did you find the problematic place in the source code? I tried to find it, but couldn’t.

Now the available versions list shows:

  • 21.0-Omeg
  • 21.0-Omeg
  • 21.0-Omega-rc2
  • 21.0-Omega-rc1
  • 21.0-Omega-beta3
  • 21.0-Omega-beta2

  • :grimacing:
    Did anyone confirm if either one of those “21.0-Omeg” works?

As written like here coreelec:updates [CoreELEC Wiki] it’s not possible to update by this method and will never be.

Oh, it’s this one, right?

It’s not a bug in python. You’re using strip() incorrectly. The str.strip(chars) function strips away all characters in chars from the start and end of str. That’s not what you want to do there. Instead you want to remove the ‘.tar’ suffix if it exists, right?

The code should look like:

    if tagname.endswith('.tar'):

You are already looking a solution to the problem.

The “bug” was added by edit4ever committed on Dec 5, 2018 . So all releases with this changes till 21.0-Omega are affected.

As a workaround you could make a release named something like 21.0-Omega-hotfix, because that ends with ‘x’ which is none of ‘.’, ‘t’, ‘a’, or ‘r’.
Or 21.0-Omega-final. Or 21.0-Omega!.

No, it’s not recommended to perform a “update” against major release versions anyway. A clean fresh install and by restore a backup is preferred.

You should look more carefully code around and not just one line. And also code before changes and also whole update mechanism to understand. But this would took more than 2 minutes!

But thanks for suggestion.

No more discussion is needed.

I replied to Portisch’s message saying there’s a python bug related to “a split(‘.tar’) to remove the file ending” (which should’ve said strip instead of split, but whatever). I pointed out that it wasn’t a python bug, but a bug in the CE code, where the programmer had thought the strip function worked differently than it does. And I provided code that works like the programmer clearly had intended. At no point did I comment on the surrounding code, or the general methods used etc.

What 2 minutes? What are you talking about? Who said anything about 2 minutes?

Are you referring to the 2 minutes it might take for someone to add the version number to the update dialog text? If so, that’s a completely different issue (in a different topic in a different forum category), as has been made exceedingly clear.

You commented code above which works exactly like it should.

And yes, it is not a bug in python but at time of writing it was not clear what is going on.

Now that all this issue is already resolved as best we could there is really no need to discuss this anymore or delete key will be in use :laughing: