CoreELEC 8.95.4.3 not auto downloading

Hi,

The latest of CoreElec is not auto updating for me. I had the same problem with the previous version as well. Has it worked for anyone here?

I was not patient and upgraded manually (from 8.95.4.2). You can do so as well.
But it is indeed more relevant to ask if it worked for anyone .
Which version are you running?

Do you have updates set to manual?

Auto update is not working for me also. I’m on 8.95.4.2 version and there’s no notification about update.
In CoreELEC Settings updates is set to “auto”.
On previous versions auto-update worked fine.

Ditto. My Mecool KII pro is still stuck stubbornly on 8.95.4.2 despite having Automatic Updates turned on.

Me too. Not auto update. Cheers

I can also report that since 8.95.4.2, when 8.95.4.3 was released the auto-update did not work anymore. I thought the CoreElec team did it on purpose, stopped the auto-update because of the problems of the 4.3 release.

I have it set to auto as well.

I get error below on both 8.95.4.2 and .3
Same error regardless of manual or auto update.

18:34:19.899 T:3655324528   ERROR: ## CoreELEC Addon ## system::check_updates_v2 ## ERROR: (ValueError('No JSON object could be decoded',))
18:34:19.900 T:3655324528   ERROR: Traceback (most recent call last):
                                          File "/home/cdu13a/gitplay/CoreELEC/build.CoreELEC-Odroid_C2.arm-8.95.4.3/CoreELEC-settings-4feae3f3649fd9acfdc4d02ac4601f2ce29c41a7/.install_pkg/usr/share/kodi/addons/service.coreelec.settings/resources/lib/modules/system.py", line 845, in check_updates_v2
                                          File "/usr/lib/python2.7/json/__init__.py", line 339, in loads
                                          File "/usr/lib/python2.7/json/decoder.py", line 364, in decode
                                          File "/usr/lib/python2.7/json/decoder.py", line 382, in raw_decode
                                        ValueError: No JSON object could be decoded

Please post a full Kodi debug log.

Can anyone (except CE developers) confirm that auto-update worked for them to go from version 8.95.4.2 to 8.95.4.3 automatically?

No, does not work for the latest ‘point’ updates.
I thought it was deliberately deactivated during the ‘black screen combat’ versions. Apparantly not ?

I couldn’t download 8.95.4.2 image anymore so here’s the log from 8.95.4.3 with the same error as on 8.95.4.2
https://pastebin.com/raw/085FjTaX

Please try again, there was something wrong with the server, but should be fixed now.

No error now. Auto-update works again :slight_smile: thanks!

Latest update worked! Thanks to the Devs for all their hard work!

1 Like