CoreELEC 8.95.7


Two new crash logs with full debug enabled:


Can you send some more?


@daxue @ynnsn the issue is fixed in the nightly.

Issue was change in coherent dma pool size, the change has been reverted now.


Will there be another CoreELEC release based on RC5.2 or do you wait for the Final 18?

Eager as I was I installed RC5 on 2 other systems (Android and Windows) and now the SQL bug mentioned above hit me.


I’ve solved (for now) MySQL issue generally: upgraded the server and DBs to 8.x
The other way would be to downgrade respective Kodi versions to such, below the abovementioned nightly… :slight_smile:


Yeah, I know… but I was clever enough to delete the old database before I noticed the bug :roll_eyes:


As @ChimeyJimmey already suggested, upgrading your database solves the issue.
These are the database versions suffering from this problem:

  • mySQL <= 5.7
  • MariaDB <= 10.1


I tried the latest nightly 20190114 but there is another problem starting kodi:

Jan 15 19:17:01 CoreELEC systemd[1]: Starting Kodi Media Center…
Jan 15 19:17:01 CoreELEC systemd[1]: Started Kodi Media Center.
Jan 15 19:17:01 CoreELEC[3705]: /usr/lib/kodi/kodi.bin: error while loading shared libraries: /usr/lib/pulseaudio/ unexpected PLT reloc type 0xd2
Jan 15 19:17:01 CoreELEC systemd[1]: kodi.service: Main process exited, code=exited, status=127/n/a
Jan 15 19:17:01 CoreELEC systemd[1]: kodi.service: Failed with result ‘exit-code’.
Jan 15 19:17:04 CoreELEC systemd[1]: kodi.service: Service RestartSec=2s expired, scheduling restart.
Jan 15 19:17:04 CoreELEC systemd[1]: kodi.service: Scheduled restart job, restart counter is at 69.


ynnsn: Can you run sha256sum and post the result?
sha256sum /usr/lib/kodi/kodi.bin /usr/lib/pulseaudio/

You can try run this and see if kodi starts.
echo 3 >/proc/sys/vm/drop_caches

Also which image you are using?
Does it happen after reboot too?


I reinstalled the nighty and now kodi starts and crashes again like with the update to 8.95,7.


Can you read my previous reply and run those commands?
And which image you are using?
And you are saying same happen to nightly 20190114 and to 8.95.7?


sw decoding problme on 905X, i do not know if it is present on old version or not.
I use Netflix and i Know that it is sw decoded because widevine, but i have two box on a 720P monitor, one is Rpi3 on OSMC and one is S905X on CoreElec.
The first do not have problem on 720p Netflix film.
The second, same film on same network, have problem, it always stop and reload the buffer


I just want to say thanks for the great work.
One of my last replys where from the libre elec parts. I was unhappy with the 8.90.3 release (wireless problems) and keep the 8.90.1 for a long time. I was also unhappy with the removal of the installinternal command.

I have patched to 8.95.2 / 8.95.3 / 8.95.5 and again to 8.95.7 and i am very happy at the moment.


Does CoreELEC has the function to disable interlaced post processing for live tv? Wrxtasy has this in his build and it fixes live tv on s905w


Yes, you can find it in “Settings > Player > CoreELEC”.


Great thank you


Been running this version since it updated from previous version with no issues on my Tanix Tx3 Mini. Today i thought i would try using internal storage for data as I’ve never tried this before. All went well and no drama.
I then pulled out the SD Card and Inserted a a different SD Card Fresh 8.95.7 image and booted up the Tx3 Mini when i noticed the LCD Display was displaying Boot after box had booted into CE.
I rebooted into Android, LCD Came on. I rebooted back to CE and LCD showed Boot again.
I powered off . Inserted my other original SD Card , Booted up and the LCD Screen worked again.
I powered off / Inserted the new SD Card / Booted up and the LCD Screen still displays boot. Whats Up. ???


I believe it was mentioned, a long while back, that booting from an external installation on a device with an internal installation, can cause issues (duplicate partition names etc.) :thinking:


Yeah That’s why i mentioned every stage without leaving out the SD Card original install of data . This could be another issue if swapping SD Card CE Versions eg: Testing nightlies.
New Fresh Install
CoreELEC (official): 8.95.7 (S905.arm)
CoreELECTx3Mini:~ # blkid
/dev/loop0: TYPE=“squashfs”
/dev/reserved: PTTYPE=“atari”
/dev/cache: UUID=“57f8f4bc-abf4-655f-bf67-946fc0f9f25b” TYPE=“ext4”
/dev/tee: UUID=“57f8f4bc-abf4-655f-bf67-946fc0f9f25b” TYPE=“ext4”
/dev/system: LABEL=“system” UUID=“da594c53-9beb-f85c-85c5-cedf76546f7a” TYPE=“ext4”
/dev/data: LABEL=“STORAGE” UUID=“57f8f4bc-abf4-655f-bf67-946fc0f9f25b” TYPE=“ext4”
/dev/mmcblk1: PTUUID=“fcfc4459” PTTYPE=“dos”
/dev/mmcblk1p1: SEC_TYPE=“msdos” LABEL=“COREELEC” UUID=“0301-5216” TYPE=“vfat” PARTUUID=“fcfc4459-01”
/dev/mmcblk1p2: LABEL=“STORAGE” UUID=“0c2d3928-ec1e-4a12-9b42-89221da2cacc” TYPE=“ext4” PARTUUID=“fcfc4459-02”
CoreELECTx3Mini:~ #


On a clean install you need to put the correct vfd.conf file into /storage/.config. See this: