CoreELEC Amlogic-ng(4.9 kernel) for S905X/S905D/S905W - FunHouse builds

Since last post i have tested an Android 6.01 s905D 1GB/8gb box with Team CE
Real serious issues trying 1GB box with dtb.img and NG Kernel 4.9
Spent hours catching logs.
Time needed for a POSSIBLE fix


FWIW, updating my X96 S905X 2/16G to Android 7.1.2 allows it to run the NG, in a stable manner. No more segmentation faults locking up the device and making it unusable. Is there some special sauce in Android 7.1.2 that makes it possible or was the stock firmware for my box just garbage? Who can say, but it finally works.

Thanks DEVs, you folks are amazing!

To try and give the simplest answer.

The vendors firmware doesn’t just include android, but also the boot loader which is made up of a couple different binary blobs.

Besides handling booting the device, these bits also handle some hardware access for the running OS, and stay running in a separate secure thread on the device. The kernel talks to this thread, and makes requests of it when it needs certain things.

This is were the the problems with old firmware come into play. The kernel expects to ask for stuff in a certain way, and get a certain answer back. As development continues some of this ends up changing, either to fix issues or to make things more flexible or efficient.

Normally when a vendor updates firmware, they update both the boot loader and kernel at the same time, so there doesn’t end up being any issues. This hasn’t been an issue for CoreELEC in the past because the 3.14 kernel was just as old as the old firmware. But, the 4.9 kernel is much newer, so there is a chance of issues with older firmware, and having a miscommunication that causes a problem. I have patched a few such issues, and will try to fix more of them when possible.


Hi guys, I have two 1/8GB S905X boxes, an X96 and a Trongle X4, both kernel 3.14 internal installs. I’d like to upgrade them to NG but I don’t have their stock Android which IIUC is needed to upgrade internal installs.

Does anyone know if this ROM works on them?

Ahhh. Thanks for the explanation. Makes more sense now.

I haven’t had any experience with that one, I personally used the Tanix TX7 firmware, google: HQYG-TX7-nikodi-20180104. Wifi drivers, etc work on my X96. According to some lengthy forum reading on XDA/Freaktab, (which is how I came to it, however long ago), it’s reported to work on many boxes. I’ve personally used it on a few S905x varieties without issue. On one box, I wasn’t able to boot to CE using the toothpick method, I had to use the update from within Android method.

If you don’t have a working stock firmware, I’d personally be cautious as if it doesn’t work, you’re kinda hooped.

Tanix firmware is for 2GB hardware

Through Burn Card Maker, the original firmware is flashed without problems, this firmware is not. (vontar x96 1/8/100 s905x original firmware android 6.0.1-17.06.09).

I have a vontar x96 1/8/100 s905x original firmware android 6.0.1-17.06.09. CoreELEC-Amlogic-ng.arm- -constant reboot (bootloop). CoreELEC-Amlogic -.arm- - ok.

There is another issue with 1gbdevices which we have identified.
Issues with 4.9 Kernel
Stay with 3.14 for the time being.

1 Like

Well, I’ll do that.

Correct, however I have installed this rom without issue (with the exception of non-working wifi) on a friend’s cheapo 1/8GB box that arrived bricked with no available stock firmware that I could.

Thanks for the input guys, I’ll wait for the fix for 1GB boxes and meanwhile do some more research on XDA and Freaktab.


I am using latest version ( on La Frite with 1 GB RAM.
Everything works fine except CEC – I tried both versions of the CEC library.
On header 9J3, jumper is in left position (when HDMI connector is to the right).

I installed the 9.2.4-ng version on my S905D device. It mostly works but I have 2 problems.

  1. The ng version somehow modified bootloader even I replaced the aml_autoscript with my own script worked in non-ng version. Specifically, the ng version changed the ‘switch_bootmode’ uboot env-variable. This makes my device can not boot the non-ng version usb disk, but can boot ng-version. I had to change the variable back to boot non-ng version.
  2. The ng version can not play 4k HDR videos. My TV just loses signal when the 4k HDR video starts. I checked kodi log but no errors. The non-ng version plays the same videos without any problem.

We have moved to [ already.]
No need to keep your hardware model a secret either.

Ok. Nothing secret here. The device is Phicomm N1. Actually I tried too and the result is same.

I compared the log when playing the same 4k HDR file between non-ng and ng versions:
non-ng version:
2020-08-22 00:30:51.132 T:4090634816 NOTICE: Whitelist search for: width: 3840, height: 2160, fps: 23.976, 3D: false
2020-08-22 00:30:51.133 T:4090634816 NOTICE: Display resolution ADJUST : 3840x2160 @ 23.98 - Full Screen (36) (weight: 0.000)
2020-08-22 00:30:51.554 T:4090634816 NOTICE: VideoPlayer: OnLostDisplay received
2020-08-22 00:30:51.554 T:4090634816 ERROR: GetString: error reading /sys/class/amhdmitx/amhdmitx0/custom_mode
2020-08-22 00:30:51.848 T:4090634816 NOTICE: VideoPlayer: OnResetDisplay received

ng version:
2020-08-21 23:12:17.929 T:4092355136 NOTICE: Whitelist search for: width: 3840, height: 2160, fps: 23.976, 3D: false
2020-08-21 23:12:17.930 T:4092355136 NOTICE: Display resolution ADJUST : 3840x2160 @ 23.98 - Full Screen (39) (weight: 0.000)
2020-08-21 23:12:18.154 T:4092355136 NOTICE: VideoPlayer: OnLostDisplay received
2020-08-21 23:12:18.155 T:4092355136 ERROR: GetString: error reading /sys/class/amhdmitx/amhdmitx0/custom_mode
2020-08-21 23:12:18.351 T:3403658112 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer
2020-08-21 23:12:18.446 T:4092355136 NOTICE: VideoPlayer: OnResetDisplay received

There is one WARNING line with the ng verson:
2020-08-21 23:12:18.351 T:3403658112 WARNING: CRenderManager::WaitForBuffer - timeout waiting for buffer

After more testing, I have one correction. The 2nd problem is only with 4K HDR video file, not normal 4K video. So the problem is with 4K HDR. I tried both turning on/off the HDR to SDR conversion and the result is same.
Another issue, CE keeps waking up my TV through CEC. It turns on the TV immediately after I turn off my Sony TV while CE is running.

Sounds like your TV doesn’t like the 10bit input signal CE is outputting.
Try enabling the Force 4:2:2 Chroma in the CE settings and reboot, see if that helps.