CoreELEC Amlogic-ng(4.9 kernel) for S905X/S905D/S905W - FunHouse builds

If anyone else ever comes across this: It worked for me with the factory Nexbox A95X Image from here:


Had no luck with some custom firmwares I tried, they all refused to boot from sd. The Android won’t have wifi, but I did not care a bit, as I just use this box for coreelec anyways. Was surprised as well that it worked, as it’s obviously not for the A95X A1 box…

Wonder if you’ve already tried this firmware on your box - seems to be quite compatible with many boxes:

Firstly, I would like to thank the devs for all of their great work on CoreELEC!

As for my situation:
I have an OTT A95X A1 1G/8G box (probably a clone), the one with the weird v2.0 motherboard and weird wifi. I had the 9.2.8 version installed into the internal emmc as an only os and it was working fine for a few years already. The original firmware was most probably 6.0 based.

I wanted to upgrade to the ng build. I have tried booting it, but it was freezing up after a few seconds after the boot into kodi. After some research, I was able to upgrade the device with an USB-A - USB-A cable and amlogic burning tool (v3.1.0) to the 7.1 firmware available in the above mentioned link (MEGA this is it if freaktab goes down again).

After upgrading, the bootlogo changed to the Nexbox one, Android was able to boot fine. To my surprise, even the Wi-Fi worked. I tried booting the ng build again - I pressed the button inside of the audio 3.5mm jack and kept it pressed until the coreelec logo showed up, anything less and it would boot into android; I had the flash drive in the USB slot closer to the front of the device. Afterwards, coreelec booted just fine, I installed it into the internal emmc and everything seems to be working fine for now. The device seems to be a little snappier, but I might just be imagining things.

Thanks so much! This also worked for my Eminent EM7680, which previously just bootlooped and kept crashing with 19.3. Here is what I did:

Booted into windows and downloaded NEXBOX-A95X_S905X_7.1_8189_8g1g_171118preview_SD_USB.rar and Tool_USB from that MEGA storage link. I hooked my hacked A-to-A USB cable between my laptop and the USB port closest to the SD card reader. I started the USB tool and held the reset while powering on the box. Then I could download the fie aml_upgrade_package.img to the box and in about 5 minutes it was done. After a reset of the box it took another five minutes before the Nexbox software was fully loaded. Inserting the SD card and rebooting, coreelec 19.3 was loading up nicely.

Hi @brupje, I am really glad that it helped someone. I had a pretty hard time finding the correct files, everything seemed to lead to rotten links :confused: Enjoy your fixed box :yum: