Coreelec does not boot in X96 mini

This is CoreELEC, not Openelec. But I’m glad you got it working.

4 Likes

Sorry to butt in,I’m having the same probs with my X96 Mini 2Gb 16Gb.
Aida64 reports numerous sd devices as blocked in \system\blocked.
Could erasing these would that allow booting from sd cards??

1 Like

Wow CoreElec worked out of the box for my X96 Mini 2gb/16gb.
Everything works so smooth including the Wifi.
Great work CoreElec Team. Thanks for supporting so many devices.

Cheers

Hi,
I installed 9.2 stable on a X96 Mini with suggested dtb (gxl_p281_2g.dtb), the box booted and resized the SD partition correctly, but then it went in a reboot loop after the Coreelec splash screen.
I tried the nightly then, and with the new dtb the device booted fine, so I tried the stable release with the dtb from nightly and the device also booted fine (no loops).
Currently I run 9.2 stable with dtb file from nightly.
I also noticed a (maybe) incorrect load average: uptime reports an average load >7, but with top I see all cpus >80% idle. Iostat reports low iowait (<0.5%). Temperature is critically high though, >60°C in idle with the case open, 85°C when playing movies.
Any ideas?
I’ll help, if necessary, by providing additional details to debug this issue.
Thank you

Can you please do a fresh install of Nightly.
Run it and report how it runs ?
Not sure what’s going on with the stable 9.2 on your box.
Just to compare if the fresh nightly works before trying 9.2 again.

I had the same problem: I tried to run 9.2 stable on my X96 mini (2GB ram).
It boots, it resize the partition then reboots. Until then, no problem. But after that it goes into an endless reboot loop. It boots up to the Coreelec splash screen, display Coreelec version then reboot… in loop.

I’ve tested with different dtb : gxl_p281_2g.dtb, gxl_p281_1g.dtb, 212, etc…
From readings on forum I started suspecting a bad SD Card, a fake X96 mini with Rockhip CPU, etc… But I tried an old community version of LibreElec (LibreELEC-S905.arm-8.2-8.2.3.1.img) with gxl_p281_2g.dtb and it just runs fine.
So I gave a try to CoreElec nightly (CoreELEC-Amlogic.arm-9.2-nightly_20191003-Generic) with gxl_p281_2g.dtb and it also runs fine.

So there is something problematic with the stable version on X96 mini that has problaby been corrected on the nighly version…
Note: the Nightly version of CoreElec with gxl_p281_2g.dtb extracted from the Stable version does also works…

1 Like

I had the same problem. Forever booting in the Coreelec menu. I had to download the nightly version. The stable version does not work.

update: 9.2 stable (with its dtb file) on x96 mini 2g boots fine after the first full boot with the nightly version, no more loops. weird.
after taking care of the cooling problem with heatsinks, a fan and some pain, cpu and gpu are both under 50°C, no more offline cores.
the problem with the undiagnosticable high load ( >6 ), despite high cpu idle time and low iowait remains. I tried blacklisting unnecessary modules and the best progress was made getting rid of ssv6051 (after this load dropped 50%, with an usb wifi interface running) but of course that means no integrated wireless.
another thing I noticed is that 90% of interrupts (no balancing here: most interrupts are on cpu0, maybe this is improvable) are by sd_emmc, with zero i/o load.

Hi. I had the same problem in two x96 mini 2gb/16gb. After one month testing all the dtb img of the device tree I´ve got boot coreelec from a miniSD with the coreelec 9.2.1 version using a TV model LG ( 19LD320-ZA) .But If I conect this tv box in others TV I can´t see anything, the screen stay with the image in black, but if i test with the app Fing detect coreelec conected to the network. Anyway I couldn´t install coreelec in the internal memory using the only TV that allow me boot coreelec from the miniSD.

Hi,

got a x96 mini 2gb/16gb @ Android 7.1 too. Coreelec (current + nightly) failed with all 212* and 281*.dtb files available in both versions (current + nightly). Stucks right in the x96 mini screen. Inserting an empty SD-Card instead of this filled one and I land in the android rescue menu.
Other boxes here work flawless but this is my first s905w soc. AIDA64 shows that it is not a fake Rockchip or similar.

Seems the device is rooted as I was able to extract /dev/dtb.img and backup it. But as it is 256k sized I assume it is not something I could directly use. Nonetheless I tried and still miserably failed :smiley:

So what now: how to make it boot or debug boot? And no, I do not have intentions to open the device up (could still send it back - with shipping costs) and also am not owning any UART-connector-stuff.

Thanks for your help and/or suggestions.

bye
Ron

Today with CoreELEC 9.2.2 after what I have read everything in this fiber I have to use gxl_p281_1g even if I have 2GB version of this X96 but it doesn’t work with gxl_p281_2g sadly :frowning:

Maybe you have a box with fake ram…
It wouldn’t be the first time…

Same thing with my x96 mini v2.3. ONLY boot with nightly version and with gxl_p281_1g but my remote won’t work. :frowning: any One with the same problem? Any solution ?

Already try it… any solution?

First You can search the repo - maybe there is a remote file You can use
Second You can create Your own -> How to configure IR remote control

Already tried too … when i press buttons on remote , nothing happens. Already tested the remote in another box and work.

Connecting to 192.168.2.25 port 22, please wait…
login as:
root@192.168.2.25’s password:
##############################################

CoreELEC

https://coreelec.org

##############################################

CoreELEC (official): funhouse_2011.6 (Amlogic-ng.arm)
CoreELEC : ~ # systemctl stop kodi
CoreELEC : ~ # systemctl stop eventlircd
CoreELEC : ~ # ir-keytable -p NEC,RC-5,RC-6,JVC,SONY -t
Protocols changed to rc-5 jvc sony nec rc-6
Testing events. Please, press CTRL-C to abort.

^C
CoreELEC : ~ # ir-keytable -a /storage/.config/rc_maps.cfg -s rc0
Old keytable cleared
Wrote 31 keycode(s) to driver
Protocols changed to nec
CoreELEC : ~ # systemctl start eventlircd
CoreELEC : ~ # systemctl start kodi
CoreELEC : ~ #
Connection to 192.168.2.25 has been terminated!

Exactly which remote file did you try?

And is it the same remote file you used in the other device? Please name the other device

Tanix tx3 mini. it’s strange I can’t wake up . It’s normal?

Unplug it, & plug back in.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice