CoreELEC fail to fetch addon repository

While I’m trying to fetch Kodi repository on my coreelec device I got a Faild to connect error. And when I tried to open the URL from the addon xml config file, which is it redirected to and returned 403 Forbidden. returns the same 403 error, but works just fine.

I’m not sure if there’s something wrong with my operation, help plz

p.s. My coreelec is fresh installed

Post kodi debug log.

It looks like have issues. It’s out of our control as it’s a service by Team Kodi. It always return But it should rotate between their different mirrors if one goes down like now.

We try to compensate it temporary until TK fixed the issue.

So maybe should I just wait ? And once TK solve the issue, my installation will connect just fine ?

Hi guys
Newbie with Homatics R 4K + box , not so new in CE world , but I have problems and dont know how to solve them
I installed and boot into CE 20 , 21 , both stable and nightly versions , NE and NG , but once when I try to install some addons ( for example Elementum ) I got dependencies errors , moule kodi-six or module.script requests , and installation is abandoned
Also when I try to enter Kodi repository I got message - could not reach repository
Internet connection is active and working , both wired and wifi
Android version is 5.4.210-ab6261
What to do to solve this issues
Thanks in advance

Try and try again until finished. have some dead mirrors included:
CoreELEC fail to fetch addon repository - #4 by Portisch

1 Like

Got me a Nokia 8010 and tried both latest nightly Coreelec 20.5 and 21.5 but I get an error trying to access the Kodi add-on repository “Could not connect to repository”. Internet works fine and I can reach other repos. Anyone has a fix for this?

Just look on link in post above Yours

Strange. Works perfectly fine on my older Odroids. What is the difference I wonder?

Kodi Leia? It uses a different server because of wrong configuration in nignx.

Ah ok, thanks. Guess one will just have to wait then…

Hi, i have problem to instal SCC addon from Hacky repo. There is no script avilable for instalation. Any suggestions?

As mentioned before - numerous times - there is a problem on team Kodi side with mirroring Kodi add-ons. Nothing to be done, except being patient, until team Kodi fixes the issue.

I tried CoreELEC Nexus 20.5 (Stable) on device X96 max plus (Amlogic S905X3 rev b, 4GB, 1Gbit).
I tested CoreELEC and booted successfully from USB, even not using the reset button method. This is my first experience with Coreelec. So far i use Kodi app on my home pc with Windows10 with no issue, on the same home network as my new X96 max plus.
The first i wanted to check on a clean installation is a connectivity to Coreelec repository (Settings - Addons - Install from repository - Coreelec Add-ons ver. 20.5) - It works fine. Then i wanted to check the Kodi Add-on repository connectivity (Settings - Addons - Install from repository - Kodi Add-on repository ver. 9.9.0), that ended with error “Could not connect to repository”. I tried to restart whole device (unplug the electricity for more than 10 minutes) and after then, the error still persists.

Via Samba i have checked the Coreelec/Addons/ directory and there is no “” directory.

This is the exact behavior I’m seeing. I’m sort of new to the whole CoreElec thing and did a fresh install last night and noticed that there is no folder or XML for the official Kodi Add-on Repo.

I did read through the thread and saw all of the mentions of there being an issue with mirrors that only Team Kodi can fix, but figured I’d mention that I am seeing the same thing with the folder missing in the addon directory.

Looks like it’s working again :+1::+1:

1 Like

Not for me

Make kodi debug log to see what happens. Saying “it doesn’t work” doesn’t really help to troubleshoot.

Well it’s the same problem as everyone in this thread has/had. Kodi repository can’t be connected to.

Well, the problem is that some things get changed. And without new kodi debug log nothing can be fixed because the issue is not known.