CoreELEC on internal

Hi guys,

I’ve used LibreELEC, OpenELEC and CoreELEC before on many other devices.
But this was a long time ago and the devices / hardware has changed.

I’ve bought myself an X96 MAX device and it works like a charm.
However I’d like to get rid of all the Google bs and install CoreELEC to internal.
I’ve downloaded myself the right CoreELEC (S905X2 variant) and used the right .dtb file (which I changed to dtb.img).

As soon as I boot from the USB / SD it works just fine. However, as I told above I want it to install to internal.
I’ve tried using Putty to installtointernal, but it shows me the line ‘-sh: installtointernal: not found’.
Are there any work arounds to get rid of this? I’ve read online and it says I should use the _nand image, but I can’t seem to find it or it isn’t available at all.

Any creative minds in here?
Thanks in advance!

Just read a little on this forum and you will find the answer.


Yeah, I’ve read a lot about it but I can’t get it solved.
Most of the post just say try different trees, but I can’t seem to get one working.
I’ve read it was removed in an earlier version of CoreElec, can I just download an old one and upgrade afterwards?
I don’t think that’s possible due to the fact that I’ve got the S905X2 and only the most recent software is viable or am I mistaking?

installtointernal is not supported on Amlogic-ng builds.


Thanks for your reply.
I did notice this, but I’ve read that ‘not supported’ doens’t mean it won’t run.
Can I make it work or can’t I? If the last thing is the case, please let me know :wink:

installtointernal doesn’t only unsupported but doesn’t exist in -ng builds.


So that means I will not be able to install CoreElec to internal?
Or is there another way to get it installed?

No way that we condone.
But go over the forum, maybe you will find something.