CoreELEC with IPTV Archive support


According to the link you posted, {utc} is what you need to get the start time of the program in UTC format.
If you’re going to implement a server for this purpose, you can implement the logic of generating the correct URL on the server, rather than having to come with some custom solution in the archive addon for your specific provider.


It looks like to play recorded event from epg, I also need event duration, like this:

Unix timestamp (utc) + duration in seconds

My purpose is to capture real traffic.


Show an example of a playlist for the archive to work, here is my example with it not working, what am I doing wrong?

#EXTM3U url-tvg=“xxxxtvg/xmltv.xml.gz”
#EXTINF:0 tvg-name=“Первый канал (Орбита 3 +4)”,Первый канал catchup=“default” catchup-source=“http://91.xx.xx.115:80/1tv/index.m3u8/?start=${start}” catchup-days=4,Первый канал


Here is example for two channels:

#EXTINF:0 catchup="default" catchup-source="{utc}&lutc={lutc}",Jim Jam
#EXTINF:0 catchup="default" catchup-source="{utc}&lutc={lutc}",Nick Jr

Most probablly your provider is using different format for archive since I see udpxy package is being used to convert multicast streams to https. You have to “sniff” your network traffic to see what kind of messages are used to point player to right archive programme.


I have the same situation as the user giaur500 - server archive on Flussonic


As my server archive seems to be Flussonic, I am still unable to access archive as Flussonic docs says. I tried to get archive m3u according to their docs, but server returns “no dvr” error. I’m going to test with SipTV to determine if archive is actually up now.
Have you even succeded with accessing archive? You can generate archive links as Flussonic docs says and test them with VLC or Chrome (download m3u).

Flussonic does not accept cathup-source syntax.


alas :neutral_face:


it turned out :rofl:, the link should be of the following form

#EXTINF:0 tvg-name=“Первый канал (Орбита 3 +4)”, catchup=“default” catchup-source=“http://91.курилынаши.115:80/1tvv/index-{utc}-360.m3u8” catchup-days=“4”,Первый канал


Could someone help with correct format to use.

My catch up link is in the following format



Shouldn’t be too hard, these are the placeholders:

  • {utc} - The start time of the program in UTC format.
  • {lutc} - Current time in UTC format.
  • {Y} - The 4-digit year (YYYY) of the start date\time.
  • {m} - The month (01-12) of the start date\time.
  • {d} - The day (01-31) of the start date\time.
  • {H} - The hour (00-23) of the start date\time.
  • {M} - The minute (00-59) of the start date\time.
  • {S} - The second (00-59) of the start date\time.

So if what you’ve posted is accurate, it’ll look like this:


What I’ve tried in the Archive URL Format is


But no luck. I’ve tried both Play from EPG in live mode, on and off.

Anything else you could suggest?

Many thanks


Maybe the duration is wrong, it’s either in seconds or minutes, so try 60 or 3600. 31500 is probably way too large of a number.


Here another,

This show was on for an hour, so not sure why it’s showing the duration of 7200.

Am I right in saying the Archive URL Format is

Thanks Paul


I think colon character should be escaped with %3A.

1 Like

Thanks for the reply, could you give me an example

Should it be this?


hi guys, dug out my old(ish) A95X box, it did an auto update to 9.0.1
I’m missing the option ‘CoreELEC Nightly Add-ons’ from the repository, I just have ‘CoreELEC Add-ons’ and kodi and kodinerds!
Anyway I installed it from the CoreELEC add-ons, so got nightik - but the option to 'run’is greyed out…any ideas?


Nightly addons repo is only available on the nightly builds, instead of the stable branch addons.
You don’t “run” the iptv addon, after you configure it, you’ll have a TV menu entry in Kodi home screen.

1 Like

thanks for reply
ok I still don’t get anything in the TV options…no channels, no guide, no recordings…
is there a ‘test’ M3U play list to try?
EDIT: i’ve updated the box to use nightlies and updated PVR iptv addon to now…
EDIT2: ooh ooh it’s working! I used fluxustv to test it out…
Rock on CoreELEC :yum:


Am i right in saying the archive(catch up) link you need to decipher to the format for the Archive URL format.

Still can’t get this working for my provider king

The normal channel playback URL is in the following format

Any help would be gratefully appreciated



I use tvheadend server with 4 tuners: 2 DVB-T tuners, 1 satellite tuner, and 1 IPTV* subscription similar to I have grouped the TV channels into tvheadend, this means that tvheadend server is responsible for providing each TV user with the available channel (DVB-T, Satellite or IPTV), tvheadend server also has permanent timeshift, and recordings. Of course from Kodi I can move forward, go back and record. tvheadend server can provide several TV channels that are inside the same mux, in each tuner. My CoreELEC is installed on a SSD hard drive and it works really well.

The problem is in the extensive IPTV subscriptions with thousands of channels because tvheadend generates a mux for each IPTV channel. I have solved this with that allows filtering the countries that have interest, once the filter is activated, only these countries are downloaded. Check in the forum of your IPTV provider how to make a filter.

(*) Be careful in tvheadend with indicating the number of simultaneous accesses to the IPTV tuner (usually one).