Delay while seeking in video

I’m running CoreELEC 9.0.1 on a WeTek Play 2. When I seek in any video there’s a noticeable delay for both the video and the audio stream. Even if the skip delay is set to 0ms in the settings, there’s still a delay when I seek in videos. What’s worse is that the audio delay is even longer than the video delay when I’m seeking.

I’m coming from LibreELEC and I’m used to being able to seek in videos pretty much instantly with almost no delay in either video or audio. I need to know if there’s any way to get rid of that annoying delay in CoreELEC (it feels to me like it’s a “feature” that’s there on purpose, but maybe I’m wrong).

Any help with this would be greatly appreciated.

Whaich version of Kodi did you use on LE, and which on CE?

Have you disabled all other seek steps except for one going + and one going -

I used both LE 9.0.1 and CE 9.0.1 and both use Kodi v18.1 as far as I know.

I tried using the same configuration from my LE on CE and I noticed the delay in seeking. Then I wiped my copy of CE and started clean, in case it was my config files that were causing the problem. The issue was there right from the start. Then I tried a fresh copy of LE too and it had no seeking issues.

Both LE and CE were tested using microSD cards not internal, if that makes a difference.

I have a Play2 with CE 9.01 on a micro SD and I have no problems with seeking. However, I stream over ethernet from my NAS for videos and over internal DVB-T for FTA.

When you seek is it pretty much instant? Or is the frame frozen on the screen for half a second before it starts playing again?

[edit] I just tried a different SD card. I installed the latest nightly CE on the card and the only setting I changed was lowering the seek delay to zero. But when I seek in any video there’s always a 500-750ms break in the video and audio. Then I wiped the card and went back to CE 9.0.1 and lowered the seek delay to zero. Same thing, the delay is still there. Finally, I wiped the card and tried LE 9.0.1 and it works perfectly. When seek delay is set to zero there’s almost no pause when seeking. There’s maybe 50ms delay after I seek.

No one has any ideas how to fix this problem? I can’t be the only one have this issue. I have a WeTek Play 2 and a Sunvell T95 (both are S905 based) and both boxes have this issue on every version of CE and the issue is NOT there for both boxes if I switch to LE.

I don’t think this is a bug. I believe this delay is there an purpose and I need a way to remove it. Even if I set the seek delay to 0 there’s still a full second delay every time I seek. I cannot use CE until I get around this issue. So any help would be greatly appreciated.

Yeah, guess it’s time to move back to LibreELEC and forget about this CE junk with ZERO support. Good luck to all you brave souls with tons of free time to waste on this garbage.

Sorry to see you go but good luck with LE.

1 Like