Directory browsing problems with 8.90.2

Hi there!

I’m facing a recent problem with 8.90.2, not happening with previous 8.90.1.

Kodi freezes when browsing my NAS for selecting media content.
I have tried with FTP (my first selection even with 8.90.1) and SMB, same problem.
Kodi screen freezes, so I have to reboot from ssh, even on screen debug messages get freezed.

Here are the logs:
FTP access:
SMB access:

Can anybody take a look?

Cannot confirm this.
My NFS-shares on my WIndows-PC in my home-network are browseable as before and I can play videos as with former CE-versions.

Confirm. Same problem on subtitle search.

Did you upgrade from 8.2? it looks like your box is looking for settings which don’t exist and it’s using all the CPU which would explain your directory browsing issues.

For subs a had this with other builds too. So i changed the path from „with video“ to a folder i made on the sd card … so the problem after 1-2 reboots was gone.

You are right, upgraded from 8.2 time ago.

Time for a clean install I guess… will report back when done.

Well, tried fresh install and problem solved.

Unfortunately there’s another problem with HDR flickering, will report in a separate thread.