Disable GUI Scaling

Hi - my s905x3 box shows this option but I don’t see the same option on s905x with the same 19.5 rc1 build. Anyway I can enable this option even using the command? Was it purposefully removed for s905x due to CPU limitations? If not, I’d love to have this option available as I use the very basic skin.

try nightly… it’s already fixed

thanks - unfortunately maybe we’re not talking about the same thing. I tried the nightly build on s905x but it still does not show the option to “disable GUI scaling” which would allow the system to render everything above 1080p to improve poster image resolution and such. the tv box is attached to a 4K HDR TV as well not that it would matter in my view.

Again, s905x3 shows this option on pretty much all versions of Kodi 19 (Matrix) without any problem.

Edit: also, I looked at guisettings.xml

s905x3 shows the following:
<setting id="coreelec.amlogic.disableguiscaling">true</setting>

s905x shows the following instead:
<setting id="coreelec.amlogic.disableguiscaling" default="true">false</setting>

manually changing this to true and rebooting kodi changes the settings value back to false upon reboot. also, “systemctl stop kodi” and then edit guisettings and then “systemctl start kodi” also did not help. the settings value reverted back to false.