Disable integrated IR receiver

Hello,

I have a S905X3 tvbox that works perfect with CoreElec. I add a USB IR receiver to use my own remote:

The problem is that the remote key is received twice, once by the USB IR receiver and second by the integrated IR receiver.

How could I disable the tvbox internal IR receiver?

Thank you very much for your help.

Kind regards.

Try creating file /storage/.config/remote.disable.

Quick question, and I’m sure you’ve got a good reason, but if the remote works fine with the internal IR receiver then why use an external usb one?

Thanks vpeter, I will try it when arrive to home.

Is there any command to see the different IR receivers in the tvbox?

Just to try before and after create the file.

Empty file is ok? “touch /storage/.config/remote.disable” ?

Regards.

Yes, touch is ok. And then reboot the device.

I had the same thing with my Odroid N2 and just FYI covering the IR receiver (in my case I simply turned my Odroid to face a wall though I imagine duct tape over the IR receiver would work as well) also solves the problem of double inputs if you’re looking for a simple solution.

Hey,

Thanks for the help, the command for disable the IR receiver worked (would be great to see the working IR receiver), but the orginal problem is still there.

The original problem is that when I start a recursive playback in photos, the tvbox is not responding to the remote keys. I thinked it was about the double key, but with single keys happen too. The only way to resolv is to enter by ssh and reboot.

How could I take logs about what happens?

Thanks for your help.

I am going to point you in the right direction:

https://forum.kodi.tv/showthread.php?tid=61219

Have fun.

Write exactly the procedure how can we repeat this problem.

When kodi stop responding paste kodi debug log.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice