eMMC Wake Issue

Odriod N2 4G
CoreElEC Stable 9.2.2

Hello, Recently I backed up my build into a TAR. file. My plan was to switch from my SD card to my EmmC on my N2. Everything went smooth as far as backup goes. My only issue is that now my TV will not wake my N2 anymore with the EmmC installed… Ive tried to mess about with the settings but nothing seems to wake it , even from suspend. I switch back to SD and everything works again. Hopefully someone can link me a guide, or offer some assistance regarding this issue? Thanks so much for you time!

You have both, eMMC and uSD mounted the same time? If yes please use only one a time and run a CoreELEC update by tar again to be sure the bootloader is updated on correct boot media.
Also there is a config.ini on eMMC and uSD and maybe in one it’s disabled, the other enabled.
Check Kodi->Settings->CE Settings->Hardware

1 Like

Thank you so much for the reply!! Sorry , Not mounted at same time , both done separately. Okay I will try to look in the CE Settings :slight_smile: .

Hey just coming back to this , I have copied my exact CEC settings and it’s still not waking my EmmC from suspend tried multiple different settings.

So something a bit weird. My N2 is on HDMI 3, Once I switch input to my ant/tv input it plays tv for 3 seconds and wakes / switches my input back to HDMI 3 and my N2 is now awake. If I switch to HDMI 2 / Xbox, nothing happens and I don’t wake my N2.

Here is a log if it helps. @Portisch

http://ix.io/2oLQ

You can try to disable some CEC wake up options in Kodi->Settings->CE-Settings->Hardware.
Try to disable option Active Source.

Hmm I was hopeful! I disabled the send “inactive source” command on shutdown but still no joy … would my next step be maybe buying a uart? Thanks for your time again.

I think so, yes. UART will hopefully show the reason.

Okay will order and report back soon.

@Portisch Hey man! appeciate you looking into this again. Here is some info from my UART
First one is me powering it off into suspend and then trying to wake it.

bl30 get wakeup sources!
process command 00000006
bl30 enter suspend!
Little core clk suspend rate 1896000000
Big core clk suspend rate 24000000
store restore gp0 pll
suspend_counter: 1
Enter ddr suspend
ddr suspend time: 15us
alarm=0S
process command 00000001
GPIOA_11/13 off
cec ver:2018/04/19
CEC cfg:0x007f
WAKEUP GPIO cfg: 0x0000, bank: 0x00
use vddee new table!
08915d0000000000set_remote_mode 0x00000000cec reset
Set cec pinmux:0x11
kern log_addr:0x01
Set cec log_addr:0x01,ADDR0:11
customer pwrkeys for IR is NULL, use defaults!
customer pwrkeys for IR is 0xf708fb04
cec R: 5f 84 10 00 05
RX_OK
cec R: 5f 84 10 00 05
RX_OK
cec R: 5f 72 01
RX_OK
cec R: 5f 72 01
RX_OK
cec R: 5f 72 01
RX_OK
cec R: 5f 84 10 00 05
RX_OK
cec R: 5f 72 01
RX_OK
cec R: 01
RX_OK
cec R: 01
RX_OK
cec R: 01
RX_OK
cec R: 01
RX_OK
cec R: 01
RX_OK
cec R: 01
RX_OK
cec R: 01
RX_OK

Second is me switching sources to wake

customer pwrkeys for IR is 0xf40bfb04
customer pwrkeys for IR is 0xa659fb04
customer pwrkeys for IR is 0xa659fb04
customer pwrkeys for IR is 0xa55afb04
cec R: 0f 82 00 00
RX_OK
use vddee new table!
exit_reason:0x08
Enter ddr resume
DMC_DRAM_STAT3: 0x544
ddr resume time: 3198us
store restore gp0 pll
cfg15 3b01000
cfg15 83b01000
Little core clk resume rate 1896000000
Big core clk resume rate 24000000

by eMMC or uSD? I will need a log from both media.
On current log the device got wake up by CEC: 0f 82 00 00

Sorry those logs were eMMc. I will try SD here shortly and post

post also the output of:
cat /flash/config.ini | grep cec_func_config
once booted by eMMC, once by uSD

SD woke from suspend , SD shutdown, then woke again.Okay will try those and post

customer pwrkeys for IR is 0xf708fb04
cec R: 01 44 6d
RX_OK
use vddee new table!
exit_reason:0x08
Enter ddr resume
ddr resume time: 122us
store restore gp0 pll
cfg15 3b00000
cfg15 83b00000
Little core clk resume rate 1896000000
Big core clk resume rate 24000000
bl30 get wakeup sources!
process command 00000006
bl30 enter suspend!
Little core clk suspend rate 1896000000
Big core clk suspend rate 24000000
store restore gp0 pll
suspend_counter: 2
Enter ddr suspend
ddr suspend time: 15us
alarm=0S
process command 00000001
GPIOA_11/13 off
cec ver:2018/04/19
CEC cfg:0x007f
WAKEUP GPIO cfg: 0x0000, bank: 0x00
use vddee new table!
08915d0000000000set_remote_mode 0x00000000cec reset
Set cec pinmux:0x11
kern log_addr:0x01
Set cec log_addr:0x01,ADDR0:11
customer pwrkeys for IR is 0xf708fb04
cec R: 01 44 6d
RX_OK
use vddee new table!
exit_reason:0x08
Enter ddr resume
ddr resume time: 123us
store restore gp0 pll
cfg15 3b00000
cfg15 83b00000
Little core clk resume rate 1896000000
Big core clk resume rate 24000000

Post this in Minicom? or terminal

doesn’t matter, shh or uart is ok

SD

cat /flash/config.ini | grep cec_func_config
cec_func_config=7f

eMMc

cat /flash/config.ini | grep cec_func_config
cec_func_config=7f

cec_func_config=‘7f’

It had a hashtag in there.

Edit your CEC wake up CE settings once in when booted by eMMC.
It’s enough when you disable and enable a CEC option and then leave CE settings.

The output of the cat cmd should then be cec_func_config=7f and not cec_func_config='7f' .
Then it hopefully should wake up when using eMMC & CEC.

1 Like

Okay will try this sorry quite new… can I edit these in minicom? I will try to change then re boot

About | FAQ | Terms of Service | Privacy Policy | Legal Notice