EPG shifted 1 hours, reboot Kodi fixes that

#1

Since timezone changed to summer time, I’m getting epg always shifted -1 hour after cold boot. If I only power off with remote, then turn on, epg is fine. After cold boot, when I restart device (or restart Kodi), epg is fine too.

This happens with tvhadend and simple iptv addon. My device is MXQ Pro, latest Coreelec stable. Do you think this could be some kind of bug? Kodi o Coreelec issue? I have no this issue on Kodi Android. I suspect this could be related to clock reset when device is powered off (without AC connected), then after boot time and date is invalid until set from ntp

#2

Setting

Settings / Interface / Regional / Timezone country

properly fixed this for me.

#3

I found that I needed to set the NTP time servers in Coreelec setting to solve this problem.

Shoog

#4

Both solutions don’t fix that for me. I’m still getting epg shifted -1 hour. It looks like still winter time is used. Need to restart kodi to get correct epg.

It seems to be Coreelec (or Coreelec + device specific) issue. Kodi on PC or Android no issues like this, the same Kodi version.
Clock date and time displayed is always correct, only epg is shifted. So timezone is valid.

#5

This post will probably help you…

#6

Matt Huisman created an Addon for this very purpose:

9.0.2 Discussion
#7

This is general PVR issue, not only tvheadend. Anyway, your solution does not help