Error mounting NFS share at boot time [SOLVED]

Hi all,
been having an annoying problem as of late.

CoreELEC (official): 19.5-Matrix_rc1 (Amlogic-ng.arm)

I am trying to mount an NFS share at boot time via a systemd mount file. Ressource is not mounted right after CE is booted but mount completes successfully after I run

systemctl start storage-film_posters.mount

from the command line. Needless to say the file was enabled for boot time with

systemctl enable storage-films_posters.mount

This is the content of said systemd file:

CoreELEC:~ # cat .config/system.d/storage-film_posters.mount
Description=Montage ressources posters

To troubleshoot this I checked that:

  • in CE settings I have wait for network set to 15 s
  • there are no NFS related errors in dmesg:

CoreELEC:~ # dmesg | grep -i nfs
[ 0.632493@0]- RPC: Registered tcp NFSv4.1 backchannel transport module.
[ 0.708363@3]- FS-Cache: Netfs ā€˜nfsā€™ registered for caching
[ 0.709195@0]- NFS: Registering the id_resolver key type
[ 0.709353@0]- nfs4filelayout_init: NFSv4 File Layout Driver Registeringā€¦
[ 0.709359@0]- nfs4flexfilelayout_init: NFSv4 Flexfile Layout Driver Registeringā€¦
[ 6.680680@0]- Installing knfsd (copyright (C) 1996

  • there are no other errors that might be related in dmesg:

CoreELEC:~ # dmesg | grep -i error
[ 0.910391@3]- dim:err:dim_get_vpu_clkb: get clk vpu error.
[ 1.127698@3]- request_irq error ret=-22
[ 1.137558@3]- defendkey: probe of ff630218.defendkey failed with error -22
[ 1.161192@3]- snd_tdm ff660000.audiobus:i2s2hdmi: aml_tdm_get_pins error!
[ 2.327895@1]- init: ### No filesystem errors found, continuingā€¦

Can anybody point me to what is wrong, please?

just wondering if anybody had any idea as to my little problemā€¦

After reboot check what service tells

systemctl status storage-film_posters.mount -l --no-pager

Hi vpeter,
thx for spending some time. Now systemctl status command oddly returned disabled which intrigued me since I know for a fact that I did enable the service in the first place. Well, it turns out that after enabling the service again and rebooting, everything is now peachy. I am a happy camper again.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.