Error "the dependency on kodi.binary.global.main..."

#1

So, as I said in the 8.99.1 version topic I had a problem updating. So I went back to 8.95.7 and when I try to install PVR add-ons (simple client and tvheadend client) I get the error “the dependency on kodi.binary.global.main version 1.0.14 could not be satisfied”. Does anyone know a solution to this error? I’ll try and post a log later if necessary! Thanks!

EDIT: tried to upload log but I can’t see any short URL when I press upload log. I followed the guide and nothing happens.

0 Likes

#2

As explained in PM, each time we do a new release we recompile all of the binary addons so you will only find them compatible with the latest release.

Now we are at final this will not be an issue with future releases, if you are having an issue with the latest release then I would encourage you to tell us what the issue is so we can help you rather than rolling back to a previous version, this doesn’t help us or you.

Uploading logs was only fixed in the latest version.

0 Likes

#3

As said in the 8.99.1 thread, the dvb module with media build is not working. In the meantime I’ll try to install the addons I need in the 8.99.1 version, make a backup, revert to 8.95.7 and try the backup to see if the addons work this way. And upgrade to 8.99.1 when the media builds work.

0 Likes

#4

They wont sorry

0 Likes

#5

Back to Libreelec while you guys figure it out… If there’s the need for some testing please inform!

0 Likes

#6

This is why you should make a backup before upgrading

It will be fixed in the nightly release soon

0 Likes

#7

I know, huge mistake! Everything went very well in previous releases…

0 Likes

#8

Hey guys, I have the same error.

Clean install of CoreElec 8.95.7 (device tree gxbb_p200_2G_100M).

When I install PVR IPTV Simple Client I get this error:

13:28:26.658 T:4090814480   DEBUG: CAddonInstaller: installing 'pvr.iptvsimple' version '3.5.7.2' from repository 'repository.coreelec'
13:28:26.664 T:3761329008   DEBUG: Thread JobWorker start, auto delete: true
13:28:26.671 T:3761329008   DEBUG: CAddonInstallJob[pvr.iptvsimple]: requires kodi.binary.global.main version 1.0.14 which is not available
13:28:26.672 T:3761329008   ERROR: CAddonInstallJob[pvr.iptvsimple]: The dependency on kodi.binary.global.main version 1.0.14 could not be satisfied.

Same thing with InputStream Adaptive:

13:39:58.390 T:3761329008 ERROR: CAddonInstallJob[inputstream.adaptive]: The dependency on kodi.binary.global.main version 1.0.14 could not be satisfied.

Let me know if you have questions. I don’t really understood the explanations earlier so please be gentle and explain what’s going on!

Thanks

0 Likes

#9

Update to 8.99.1. The addons were updated to work with Kodi 18.0 final.

0 Likes

#10

ok I re-read and understood that part where the binaries are compiled for the latest release. Since I am one release behind, makes sense IPTV won’t install.

That being said I couldn’t clean install 8.99.1 on a new SD Card, it would boot loop with the device tree gxbb_p200_2G_100M. (In fact, with any device tree, tried them all)

I was glad that the previous revision worked. Came from LibreElec kszaq’s build 8.2.3.1 previously so huge step.

Anyway that would be something to look into. I have a generic “Echolink” box: https://iti.ma/produit/echolink-recepteur-android-echolink-v9-pro/

So how can I upgrade? Do I use a nightly build? Because in the updates section there is none available.

Thanks!

0 Likes

#11

We are aware of the 8.99.1 issues.
As a workaround, please try the latest nightly, you’ll be able to install addons from the nightly repo.
And check tomorrow’s nightly build and see if it works properly for you.

1 Like

#12

Thanks ! Nightly works.

Only problem left for now is that the network stack (wifi at least, didn’t test wired) doesn’t work on reboots. Only works on shutdown / start.

When the box is powered off and I boot, Kodi will see the network card. If I reboot, Kodi won’t see it. I have to shutdown and start fresh.

Weird, same hardware as LibreElec kszaq’s build 8.2.3.1.

Weirder thing is if I plug a Wifi dongle into the USB port, the internal Wifi starts to work too right away.

Still if I reboot, both the wifi dongle and internal wifi doesn’t work (until I take it out and re-plug back in) or I do a proper shutdown/power up.

Anyway good work on CoreELEC! Sooo nice…

0 Likes

#13

I can say that this issue has been resolved as well. Amazing!

0 Likes