Everything purple after 8.95.1 update

After latest 8.95.1 update kodi starts with a purpleish cast. It’s everywhere in menus, video playback, etc…


If I revert to 8.95.0 now, do I also have to put some device tree file in update folder or is the image enough?

What is the output of?
cat /sys/class/amhdmitx/amhdmitx0/attr
cat /sys/devices/virtual/amhdmitx/amhdmitx0/config
and full log will be helpfull, not only kodi
image is enough for revert

I already reverted… but I can update again and get you full logs and output later.

That would be helpful.
Also people specify which TV brand/model you are using and how the box is connected to it.
(ie. do you have an AVR? If you do, which brand/model?)

TV: LG 55LF5809
AVR: Onkyo TX-NR636

S905X Box connected via HDMI cable to AVR.

Thanks. Could you provide the outputs @boot2k3 asked for from both 8.95.0 and the new 8.95.1?
In addition, if the AVR can show you the signal type (RGB, YUV, color depth, etc.), could you check what each version defaults to?

Also try to connect with different hdmi cable or directly, 1 user solved this issue by changing HDMI cable.

Or monitor/TV. This happens to me also today. On one monitor everything was purple-ish. But I’ve plugged gear to different monitor - with the SAME HDMI cable - and it worked.

This gets me no output?..

cur_VIC: 16
cd = 4
cs = 0
audio config: on
3D config: off

This is from dmesg: http://ix.io/1lEF
And this from coreelec settings: http://ix.io/1lEG

AVR info shows:
1920x1080p 60Hz 24bit

Here’s the log from 8.95.0: http://ix.io/1lEK

ps: do I always have to enable debug logging in settings before choosing “upload latest logs…” via coreelec settings?

Does it show rgb on both version?
Did you start avr and TV before box?
Also try different hdmi cable if possible

Same AVR info on both versions.


I did. Same purple tint.

If I do a screenshot it shows up normal, so yeah, something going on with my setup. It’s just funny this happens now only with latest update.

I also checked my AVR settings, not much I can do here. It’s on bypass, but if I change it I still have the purple colour.

I’ve started to get this too

Different box and TV here, i have a minix u9 and s samsung something don’t know the model number.
If i change the Kodi GUI to 2160 it is fine

When i set it back to 1080 It’s messed up again

Same problems over here and same output from the commands like the first posting
I have a vorke Z6 (S912)

I also had this with the nightly builds last week

What’s causing this for me is: echo 'rgb,10bit' > /sys/class/amhdmitx/amhdmitx0/attr

RGB seems to be broken right now, there’s a fix in testing for this issue.
Try using 444,10bit.

I confirm that rgb (8 or 10 bit) is broken

A fix has been pushed, it will be included in the next version or you can use tomorrows nightly.

echo “echo ‘444,10bit’ > /sys/class/amhdmitx/amhdmitx0/attr” >/storage/.config/autostart.sh

See table

60Hz RGB 8bit
echo “echo ‘420,8bit’ > /sys/class/amhdmitx/amhdmitx0/attr” >/storage/.config/autostart.sh

It is not a problem of RGB@4k resolution, it affects also 1080p and 720p, while it was working ok on 8.95.0

1 Like