Fresh install on the TicTid Tx6 Plus S905x3

Hey I’m trying to flash my TicTid Tx6 plus S905x3 with CoreELEC.

Which should be the same result as the X96 Air.
But I don’t see support on the CoreELEC website for either device.

Any pointers? I’m new to all of this and it’s a huge learning curve for me.

The pointer is your SOC
If your device is not listed, try the generic version.
S905 X2 X3
I googled your box.
Ram 4Gb
1000M Ethernet
After you’ve burned image to SD Card
Choose the device tree that matches your hardware specs and copy it to root of the SD Card.
Rename it to dtb.img
That’s it.

Quick and concise. Thank you

So I tried to boot my device up to install CoreElec. I got the code

Error in mount_flash: mount_common: Could not mount LABEL=COREELEC

I used a USB flash drive and resolved my issue. I’m up and running now. Thank you.

Hey, I have a tictid tx6 plus box and tried booting both the ng and stable builds. I tried a combo of device trees since there were none specifically that pertained to 4gb/64gb capability of my box. Any pointers are greatly appreciated. I also used a thumb drive. Thanks!

I have a TicTid TX6 Plus and installed the coreelec on the device. I have managed to work the remote but the wake-up does not work and that is why I modified the config.ini file following the instructions. Do you have solutions for wake-up, do you have meson-ir, do you have the vdf.conf file?

1-Download the nightly version.
The device tree you must use is sm1_s905x3_4g_1gbit.

2-Install to emmc
Open the Putty and connect.

ceemmc -x

3-Install remote controller and display
Download FileZila and transfer files
tictid tx6 plus (2.3 KB)
copy the file “tictidtx6plus” to /storage/.config/rc_keymaps/ and “rc_maps.cfg” to /storage/.config/
copy “keymaps.xml” to /storage/.kodi/userdata/keymaps/
copy empty “98-eventlircd.rules” to “/storage/.config/udev.rules.d/”
vdf display.7z (877 Bytes)
copy VDF.conf to /storage/.config/


4-Configure wake-up
Open the Putty

systemctl stop kodi
systemctl stop eventlircd

mount -o rw,remount /flash

nano /flash/config.ini

Replace remotewakeup decode_type remotewakeupmask…
Received IRMP code: remotewakeup=‘0xbf40fe01’, decode_type=‘0x0’, remotewakeupmask=‘0xffffffff’

sync && reboot

How is this device working for you? Any problems?

Is the button for the “toothpick method” hidden in the AV port for this device?

I just got this box, my first S905X3 box and I have a few problems.

First off, booting CoreELEC directly from SD card doesn’t work, I get the Error in mount_flash: mount_common: Could not mount LABEL=COREELEC message.

So I plugged in a USB 3.0 hub into which I plugged an SD Card reader. Now CoreELEC boots.

I managed to get the VFD.conf working.

I also added the remote control files, edited config.ini, but I still can’t wake up the box from suspend.

Also, the LED in front is a bit weird. It shows the clock, but the tiny red dot is also always on, as if the box is suspended

And if I want my IPTV list to load, I have to do it from a local file.
If I type in a URL address, the list never loads. That’s with PVR IPTV Simple Client add-on.