GPU crash with new CoreELEC 9.2.2

Hi CoreELEC team,

i’ve upgraded my H96 Max X2 Box online from 9.2.1 to 9.2.2 and was wondering about many hangs in the kodi UI.

I made a fresh installation with new sd card to prevent any configuration issues, but the freezes are still there.

A dmesg output via SSH shows the following log events, can anyone help me?

PS: This is my used dtb image: g12a_s905x2_2g.dtb

[  344.156224@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.168999@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.169006@1] mali ffe40000.bifrost: Flush for GPU page table update did not complete. Issueing GPU soft-reset to recover
[  344.169019@1] mali ffe40000.bifrost: Preparing to soft-reset GPU: Waiting (upto 3000 ms) for all jobs to complete soft-stop
[  344.281387@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.293855@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.306139@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.306145@1] mali ffe40000.bifrost: Flush for GPU page table update did not complete. Issueing GPU soft-reset to recover
[  344.418438@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.431152@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.443699@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.443705@1] mali ffe40000.bifrost: Flush for GPU page table update did not complete. Issueing GPU soft-reset to recover
[  344.555915@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.568469@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.580765@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.580771@1] mali ffe40000.bifrost: Flush for GPU page table update did not complete. Issueing GPU soft-reset to recover
[  344.692748@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.705360@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.717603@1] mali ffe40000.bifrost: AS_ACTIVE bit stuck
[  344.717609@1] mali ffe40000.bifrost: Flush for GPU page table update did not complete. Issueing GPU soft-reset to recover
[  347.169093@1] mali ffe40000.bifrost: Resetting GPU (allowing up to 500 ms)
[  347.169101@1] mali ffe40000.bifrost: Register state:
[  347.169106@1] mali ffe40000.bifrost:   GPU_IRQ_RAWSTAT=0x00000200 GPU_STATUS=0x00000009
[  347.169109@1] mali ffe40000.bifrost:   JOB_IRQ_RAWSTAT=0x00000000 JOB_IRQ_JS_STATE=0x00000003
[  347.169113@1] mali ffe40000.bifrost:   JS0_STATUS=0x00000008      JS0_HEAD_LO=0xe9eaf5c0
[  347.169117@1] mali ffe40000.bifrost:   JS1_STATUS=0x00000008      JS1_HEAD_LO=0xeac054c0
[  347.169120@1] mali ffe40000.bifrost:   JS2_STATUS=0x00000000      JS2_HEAD_LO=0x00000000
[  347.169123@1] mali ffe40000.bifrost:   MMU_IRQ_RAWSTAT=0x00000000 GPU_FAULTSTATUS=0x00000000
[  347.169127@1] mali ffe40000.bifrost:   GPU_IRQ_MASK=0x00000000    JOB_IRQ_MASK=0x00000000     MMU_IRQ_MASK=0x00000000
[  347.169130@1] mali ffe40000.bifrost:   PWR_OVERRIDE0=0x00000000   PWR_OVERRIDE1=0x00200fff
[  347.169133@1] mali ffe40000.bifrost:   SHADER_CONFIG=0x00000000   L2_MMU_CONFIG=0x00000000
[  347.169136@1] mali ffe40000.bifrost:   TILER_CONFIG=0x00000000    JM_CONFIG=0x00000000
[  347.169171@1] mali ffe40000.bifrost: t6xx: GPU fault 0x4002 from job slot 0
[  347.173161@1] mali ffe40000.bifrost: t6xx: GPU fault 0x4002 from job slot 1
[  347.173257@1] mali ffe40000.bifrost: Reset complete
[  365.307317@0] mali ffe40000.bifrost: JS: Job Hard-Stopped (took more than 50 ticks at 100 ms/tick)
[  365.307334@0] mali ffe40000.bifrost: JS: Job Hard-Stopped (took more than 50 ticks at 100 ms/tick)
[  365.807362@0] mali ffe40000.bifrost: JS: Job has been on the GPU for too long (JS_RESET_TICKS_SS/DUMPING timeout hit). Issueing GPU soft-reset to resolve.
[  365.807386@0] mali ffe40000.bifrost: Preparing to soft-reset GPU: Waiting (upto 3000 ms) for all jobs to complete soft-stop
[  368.807471@0] mali ffe40000.bifrost: Resetting GPU (allowing up to 500 ms)
[  368.807479@0] mali ffe40000.bifrost: Register state:
[  368.807483@0] mali ffe40000.bifrost:   GPU_IRQ_RAWSTAT=0x00000200 GPU_STATUS=0x00000009
[  368.807487@0] mali ffe40000.bifrost:   JOB_IRQ_RAWSTAT=0x00000000 JOB_IRQ_JS_STATE=0x00000003
[  368.807490@0] mali ffe40000.bifrost:   JS0_STATUS=0x00000008      JS0_HEAD_LO=0xed728480
[  368.807494@0] mali ffe40000.bifrost:   JS1_STATUS=0x00000008      JS1_HEAD_LO=0xefc084c0
[  368.807497@0] mali ffe40000.bifrost:   JS2_STATUS=0x00000000      JS2_HEAD_LO=0x00000000
[  368.807500@0] mali ffe40000.bifrost:   MMU_IRQ_RAWSTAT=0x00000000 GPU_FAULTSTATUS=0x00000000
[  368.807504@0] mali ffe40000.bifrost:   GPU_IRQ_MASK=0x00000000    JOB_IRQ_MASK=0x00000000     MMU_IRQ_MASK=0x00000000
[  368.807507@0] mali ffe40000.bifrost:   PWR_OVERRIDE0=0x00000000   PWR_OVERRIDE1=0x00200fff
[  368.807510@0] mali ffe40000.bifrost:   SHADER_CONFIG=0x00000000   L2_MMU_CONFIG=0x00000000
[  368.807514@0] mali ffe40000.bifrost:   TILER_CONFIG=0x00000000    JM_CONFIG=0x00000000
[  368.807547@0] mali ffe40000.bifrost: t6xx: GPU fault 0x4002 from job slot 0
[  368.808035@0] mali ffe40000.bifrost: t6xx: GPU fault 0x4002 from job slot 1
[  368.808328@0] mali ffe40000.bifrost: Reset complete

Same problems with CoreELEC 9.2.3!
I’m the only one? No problems with 9.2.1, so i think the problem comes with the new kernel in 9.2.2.
Thanks for help

Sounds like a hardware issue with your box.