Green screen issue - CoreELEC 9.2.1 - Amlogic S905X2


I got it working by editing the config.ini.
But for 4K videos the GUI when paused and the subtitles are all black and dark. Not visible. Any idea how to change that?

I just recently came across CoreELEC and I installed it on my android box.

I tried the latest with the g12a_s90X2_1g.dtb and all I got was a black screen but I still got input signal of 1080p but no video output.

So I decided to try out earlier versions and the only version that worked was 9.2.1 and lower versions. After 9.2.1 all the other three versions give me black screen.

Now the problem with this version is the UI is green. Video is good but everything else is just green.

I read on the forum that I have to uncomment a lint in the config.ini but I use a mac so I need help doing that.

Or is there any other way to solve this?

(I can’t update because the other versions will result in a black screen)

Can you tell us what you edited in config.ini?
Does now working?
Was before the CE logo shown or only the vendor boot logo?

I edited the line from “use_rgb_to_yuv = 0” to “use_rgb_to_yuv=1” and the green screen disappeared.

Its Coreelec 9.2.1.

All the other updated versions no CE logo…just a black screen after the vendor logo.

The only problem now is the GUI in-video for 2160p videos, goes black and dark. Like i can’t see anything when i pause or want to forward or choose any setting in video.

Its normal for 1080p videos.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.