Green screen on Odroid N2 under 9.2.2

Hi guys,

I have CE on a Odroid N2 (SD card, Philips TV with Full HD) and upgraded to 9.2.2 yesterday. Before the upgrade, I also suffered from the green screen issue, so every 20 minutes or so, the screen turned green, stayed green for 2-3 minutes and changed then back to normal. When I upgraded to 9.2.2 yesterday, I read, that the green screen issue is fixed now, but unfortunately, my green screen issue continues.

I read here in the forum, that some people had success by uncommenting “use_rgb_to_yuv=0” in config.ini. I did that, but the issue is still present, also when setting this option to 1.

Then I saw, that some people had success by changing the deinterlacing option, but I didn’t find it in the CE settings.

Can anyone help me with this?

Thank you for your help!

Maginos

The green screen you read about was a constant green tint to the picture, it wasn’t intermittent, and the reason for it was incompatible HDMI configuration between Android and CE kernels.
If your issue is intermittent, I’d look at other things like a bad HDMI cable.

Ok thank you, I will check that and report back.

i have an orange screen, but only when i don’t first turn on the tv and then the box.

Unfortunately, whether changing the HDMI cable, nor changing the HDMI Port on the TV solved the problem. Turning on the TV first, did also not change anything.

I will ask in Odroid forum to see, if someone can help me there.

Thank you guys for your help!

Did you try any other OS on your N2 to see if it’s only CoreElec related?

I tried, it’s not CE related, but Hardware related. On my PC monitor, Ubuntu Mate and CE run without any issue, but on my TV, Ubuntu Mate is not displayed, my TV says “video format not supported”, so I got no graphical response there. Other Hardware (TV reciever, PS4, etc.) has no problems with the graphics, it’s only the odroid. Later I can test Kodi on Raspberry Pi 3B+ as well.

Do you know, how I could change the settings on the Odroid/CE or on the TV to solve this problem?

To me it looks as it’s not CE/Odroid problem. From your tests I guess it’s a problem with some part on your TV.
Such intermittent behavior suggest a bad contact, as a result of (over)heating some component on your TV. Different devices may behave different, and maybe not “trigger” that bad contact. So if it works OK with RPi it still can be a problem with TV.

Btw, did you try to move/shake HDMI cable connector on your TV when it gets green, to see if there is a bad contact on the HDMI input. It can be even on the input HDMI board, so all HDMI inputs will have the same manifestation.

Mind you that’s just my guess, since N2 performs OK on your PC monitor.

Yes, overheating might be a problem, the TV is relatively old (2008) and gets warm of course during use.

With Raspberry Pi 3B+ it seems to work ok, I got no green screen within 40 Minutes, which is more than with the Odroid.

So maybe I call my TV specialist tomorrow and tell him the story, maybe he can help me with that.

I would really prefer to use the N2, since it is much more powerful than the Pi, so hopefully my specialist can help me quickly.

Try to connect the N2 to a different display and see if there are similar problems.
Maybe you have a bad device.

Hmm, above he wrote: “On my PC monitor, Ubuntu Mate and CE run without any issue…” so I guess he covered that option :wink:

You’re right Sholander, I connected the N2 to my PC monitor and everything worked fine.

I called my local TV specialist today and he said, that he will have look at the TV next week. If it’s a small problem that he can easily fix, I will let him do that, otherwise he said that he has to change the whole motherboard of the TV and I will definitely not pay for that.

He also said, that maybe the graphics drivers on the N2 might be an issue, so I will check, if there are some special drivers for older TVs or drivers in general, that could fix my problem.

Let’s see, what will happen. :smiley:

There are no special or different drivers for the N2 (or any other device).

You can only try running your videos with/without “Hardware Acceleration - amcodec” to see if there is any difference…

I will try that tomorrow and report back, so stay tuned. :wink:

Unfortunately deactivating hardware acceleration doesn‘t change anything, the time span of the green screen even prolongs.